Tech Community login - stuck in an automatic login loop, can't select another account to log in with


I've run into a problem with logging into the MS Tech Community Forum.   


When I click on Sign In, the browser launches a login screen/process that really wants to log me in using cached credentials.  It appears to be impossible to break this automatic log in process to change to a different set of MS Tech Community credentials.


  • I tried clearing stored credentials in settings/passwords (and then restarting the browser) -- this did not work which suggests the credentials are being stored someplace else
  • I tried hitting cancel while logging in.  I briefly see a screen with my account username, but that is fleeting because it logs me in despite having pressed cancel (lousy experience)
  • I tried deleting the old account I don't want to use anymore, hoping that would force this login process to error out and ask what account to use.  Unfortunately that's not what happened, instead it seems even more broken -- the login process gets stuck in an infinite loop.

Does anyone know how to break out of this cycle? 


After signing out, I expect to be presented with the option of selecting which account I want to use the next time I sign in.  Unfortunately this sign in process doesn't behave that way.


In case it helps, my MacOS Canary installation is logged in with the account I want to use moving forward (that's where I'm writing this post from), but my MacOS Dev installation is stuck in this weird state.






3 Replies

@Spelunky Haha -- that's a fair question!  


So I have two MacBook Pro's.  Each laptop has both the DEV channel and CANARY channel versions of Edge installed on them.  Earlier I was on laptop #1 and I could only login using the CANARY channel browser.  As I mentioned the DEV channel browser was exhibiting the strange behavior I am reporting.


I'm currently on laptop 2 and just discovered the behavior is flip-flopped - that's a new wrinkle.  I can login via the DEV channel browser but not the CANARY channel browser.    


I think something is wrong with Microsoft's SSO login system on the Mac.

I will log a new thread (so that there's evidence of multiple incidents) ... but this has been happening to me now for I don't know how long trying to get into the Power Automate powerplatform community in EDGE DEV.

I'm looking heavily at browser console stuff and things, and it's looking to my untrained eye to be an issue with:
1. The chromium Cross-Origin Read Blocking (CORB)
2. An MS OAUTH issue.
3. Both.

Anyway, yeah, REALLY frustrating, because the browser and the forums are genuinely nice to use otherwise.


Oh, and before any odd doubting, I've tried a lot of different stuff, including (but not limited to) cleansing all cookies, CTRL+F5'ing the site, multiple DNS approaches, ONLY logging in on that site (no other MS site login). And nothing.


Also, before anything about the domain login is mentioned, that's a non-starter, because if I load the site in FireFox? I can log in perfectly fine.

I have a related problem. I have subscriptions to some paid sites like NYTimes and Washington Post. Over the years, by accident or otherwise, I've accreted multiple accounts on these sites, but only one account has a paid subscription. Edge (dev version) seems determined to log me in automatically with the account it happens to like, which may not be the paid one. So, i get a message asking me to buy a subscription to say the NYTimes. I try to log out, but before I can log in, Edge automatically logs me in on the wrong account again. This happens on at least 2 or 3 sites. I have to switch to Firefox or Chrome in order to read the paywalled stuff on those sites.