SOLVED

Tabs don't load and time out, high RAM and CPU usage, browser unusable - help?

%3CLINGO-SUB%20id%3D%22lingo-sub-1080778%22%20slang%3D%22en-US%22%3ETabs%20don't%20load%20and%20time%20out%2C%20high%20RAM%20and%20CPU%20usage%2C%20browser%20unusable%20-%20help%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1080778%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20Everyone.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20am%20using%20the%20dev%20build%20of%20Edge%20Chromium%20(%3CSPAN%3E79.0.309.54%20(Official%20build)%20beta%20(64-bit)).%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EI%20have%20the%20following%20issues%3A%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3E1%20-%20New%20tabs%20are%20slow%20to%20load%20any%20pages.%26nbsp%3B%20I%20just%20get%20the%20spinning%20animation%20and%20the%20page%20itself%20I%20go%20to%20only%20half%20loads%20and%20then%20I%20get%20asked%20to%20Wait%20or%20Exit%20because%20it%20takes%20too%20long.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3E2%20-%20Pages%20are%20slow%20to%20load%20any%20content.%26nbsp%3B%20So%20pages%20I%20browse%20to%20will%20not%20load%20properly%20and%20all%20elements%20will%20not%20load%20and%20page%20is%20not%20usable.%3CBR%20%2F%3E%3CBR%20%2F%3E3%20-%20I%20have%20to%20refresh%20tabs%20many%20times%20just%20to%20get%20the%20website%20I%20want%20to%20load%20properly%20the%20first%20time.%3CBR%20%2F%3E%3CBR%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3EI%20believe%20this%20may%20be%20due%20to%20high%20CPU%20and%20RAM%20usage%20on%20my%20machine%20by%20Edge%20Chromium.%26nbsp%3B%20I%20am%20not%20sure%20how%20I%20can%20investigate%20it%20though.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20attached%20a%20screenshot%20of%20my%20task%20manager.%26nbsp%3B%20You%20can%20see%20I%20only%20have%20one%20tab%20open%20properly%2C%20a%20Google%20search%2C%20which%20hasn't%20fully%20loaded%2C%20and%20my%20CPU%20and%20RAM%20are%20rather%20high.%3CBR%20%2F%3E%3CBR%20%2F%3EAny%20suggestions%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EMany%20thanks.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1080778%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3Ehigh%20cpu%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EHigh%20RAM%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3Etabs%20unresponsive%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1080814%22%20slang%3D%22en-US%22%3ERe%3A%20Tabs%20don't%20load%20and%20time%20out%2C%20high%20RAM%20and%20CPU%20usage%2C%20browser%20unusable%20-%20help%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1080814%22%20slang%3D%22en-US%22%3E%3CP%3ESo%20it%20turns%20out%20I%20may%20have%20solved%20it%20myself.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20removed%20the%20AdGuard%20extension%20and%20everything%20seems%20to%20have%20calmed%20down%20and%20the%20browser%26nbsp%3B%20is%20usable%20again.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1080877%22%20slang%3D%22en-US%22%3ERe%3A%20Tabs%20don't%20load%20and%20time%20out%2C%20high%20RAM%20and%20CPU%20usage%2C%20browser%20unusable%20-%20help%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1080877%22%20slang%3D%22en-US%22%3ETry%20using%20ublock%20origin%20instead%2C%20it's%20better%20and%20doesn't%20have%20that%20problem%3CBR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Fchrome.google.com%2Fwebstore%2Fdetail%2Fublock-origin%2Fcjpalhdlnbpafiamejdnhcphjbkeiagm%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fchrome.google.com%2Fwebstore%2Fdetail%2Fublock-origin%2Fcjpalhdlnbpafiamejdnhcphjbkeiagm%3C%2FA%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1080913%22%20slang%3D%22en-US%22%3ERe%3A%20Tabs%20don't%20load%20and%20time%20out%2C%20high%20RAM%20and%20CPU%20usage%2C%20browser%20unusable%20-%20help%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1080913%22%20slang%3D%22en-US%22%3EThanks%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310193%22%20target%3D%22_blank%22%3E%40HotCakeX%3C%2FA%3E%20-%20I%20have%20done%20just%20that!%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1080916%22%20slang%3D%22en-US%22%3ERe%3A%20Tabs%20don't%20load%20and%20time%20out%2C%20high%20RAM%20and%20CPU%20usage%2C%20browser%20unusable%20-%20help%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1080916%22%20slang%3D%22en-US%22%3ENice%20%3A)%3C%2Fimg%3E%3C%2FLINGO-BODY%3E
Highlighted
Contributor

Hi Everyone.

 

I am using the dev build of Edge Chromium (79.0.309.54 (Official build) beta (64-bit)).

 

I have the following issues:

 

1 - New tabs are slow to load any pages.  I just get the spinning animation and the page itself I go to only half loads and then I get asked to Wait or Exit because it takes too long.

 

2 - Pages are slow to load any content.  So pages I browse to will not load properly and all elements will not load and page is not usable.

3 - I have to refresh tabs many times just to get the website I want to load properly the first time.

I believe this may be due to high CPU and RAM usage on my machine by Edge Chromium.  I am not sure how I can investigate it though.

 

I have attached a screenshot of my task manager.  You can see I only have one tab open properly, a Google search, which hasn't fully loaded, and my CPU and RAM are rather high.

Any suggestions?

 

Many thanks.

4 Replies
Highlighted
Best Response confirmed by ianwuk (Contributor)
Solution

So it turns out I may have solved it myself.

 

I removed the AdGuard extension and everything seems to have calmed down and the browser  is usable again.

Highlighted
Highlighted