Suddenly No More Homepage Upon Opening? (Bug Gone Now)

Copper Contributor

On May 29 around Noon (I think it worked earlier in the day)? Edge opens to a page chosen by Edge, not my chosen homepage.  
No amount of fiddling can make my chosen page ( appear. (Edit: See below) I have to click past their 'startup page' to get to it. That's only after I return the 'Show Home Button' to active.

The buttons to set homepages are suddenly 'greyed out' in settings. Both in Appearance and On Startup. 

Whose idiotic idea was this and why are they not fired yet?  
EDIT: Bug gone now (May 30), but what a hassle!


dftf-wip offers a solution that puts up your homepage (as well as the Start Tab in another tab). It works for me. You just have to use the 'fixed' start-link for it to work.  

Find a shortcut to the Edge browser (for example, on your desktop), then right-click it and choose "Properties".  In the Target box, right at the end (after msedge.exe") leave a single space, and then type the web-address you want Edge to start with.  Click OK, and use that shortcut now to launch Edge.

2 Replies
You need to go to New Tab Page and turn off "preload the new tab page for a faster experience"
It is turned off, but thanks!
I removed my old taskbar shortcut, and made a new one with my homepage added. This worked but now it opens in a new Edge in the taskbar... annoying eh?