Some apps get stuck in control panel

Not applicable



Sometimes I have these PWA's and sometimes they just are stuck to the control panel. Either I reset the edge before uninstalling or such. Can't uninstall the form control panel and if try in windows settings, either crash edge or it just gives me an error.


This did happen when I was using edge last year but the only way to get rid of it was to uninstall edge and uninstall that app. It said something went wrong with the installation do you want to remove it? Since it was tied to that app but now that edge can't be uninstalled. I am stuck,


Thank you, 



23 Replies
Use the feedback button or online form to report this problem, I've seen it and done the same

if you want to remove them manually, search for their shortcuts and names in file explorer. Can't help beyond that. it's a problem that needs to be reported to be fixed for everyone.
Yeah, I already reported this a year ago and that time I was with insider support that reproduced it I think. There was.s a lot of bugs when resetting or uninstalling the app after a reset or something. Some tcaused the browser to have a bad profile picture and some just not able to remove the app.
I can't find the app in the file explorer though.

Hope it is fixed soon,


I hope so too

@HotCakeX and @Deleted , you may also need to delete the registry key. If you installed some apps in the Edge 85 or 86 timeframe, we did have a bug with uninstall that could possibly leave entries behind. So after deleting the shortcuts, you should also search the registry for keys containing the name of the PWA you installed. For example: Computer\HKEY_CLASSES_ROOT\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppModel\PackageRepository\Packages\



Hi John,

Thank you very much for finding that info for me and I just followed the string you attached. I don't' see an app model in the registry. Should there be a edge update that should remove it?


thank you, now i remember i used registry at some point to get rid of the leftovers.


reading your comment, I assume the problem is solved now? by that I mean I'm expecting Edge to automatically remove all installed PWAs during uninstall and don't leave them behind.


best response

@HotCakeX Yeah, we do not have any currently active bugs regarding PWAs failing to uninstall as expected now. The only risk now is potentially having old PWAs from before the bugs were fixed and those not getting updated correctly.


So if you see something uninstalling incorrectly, please do file feedback - we'd like to get it looked at asap.



Hi John,

I am unable to the app that was previously made, do I need to do registries or should it be fixed?

I sent feedback about it with the disganotics and a video, please take a look.




Will do, thank you

@Deleted it sounds like it should be fixed. thanks so much for submitting feedback and a video, it's really helpful to the team here to read the feedback and see the issue in action.




Thanks for your reply and I have submitted this a while back and was in contact with a Edge Insider Support and they did forward it to the team.

It caused a lot of issues back then and hope it is fixed.

It isnt' fixed though since it is still stuck in the control panel and I can't get to that folder where the registries are for the apps.

in App Modules in the registries.



EDIT: When I uninstalled New Tab , it was still showing in the startmenu and had to uninstall it from the windows settings to remove it. So the issues is still there, dont' have any feedback sent about that . Please pass on to the team






It is still installed but ir ia nor in edgw

I clean reinstalled Edge canary and I don't see the option to install NTP as PWA.


As the MSFT employee said, they fixed the issue, when I uninstalled Edge canary, I had lots of PWAs, but they all were uninstalled automatically with Edge, I chose the option to remove user data during uninstall process.


you can find Start menu items in this folder for manual removal:

C:\ProgramData\Microsoft\Windows\Start Menu\Programs


registry paths mentioned above

Okay, uninstalling pwa's through startmenu works when right clicking and uninstall. But this was a pwa that was instlled after the update, why still brokeN.
Maybe when you installed it previously had some effects on it
I see, so what should I do? Reinstall Windows? I thought they fixed it. It seems it isn't.
If you want