[Solved] Canary no longer opens

Bronze Contributor



After the latest Canary update, the browser no longer opens

Does anyone have the full .exe of 105.0.1334 ?



59 Replies
Everyone here knew what we were risking by using this version as our main... Still it is surprising that something like this happened.

Another one suffering from the canary's disease xd
Thanks, I downloaded your file, unpacked it twice with Winrar... and copied accordingly.
I could have saved myself as I read now :)
ok, it works! I just have to click on the icon several times to start.
If an instance is running, I can also open further instances without any problems.
I did like you and now I'm using it without any problems. Thanks to AdeltaX, we are now using it without any problems.

For friends who want to solve problems, follow these ways.

Download the x64 version 105.0.1334.0 found on the previous page.

Open the downloaded file with winrar and open the zip file inside.

When you open the winrar file, you will see the 105.0.1334.0 folder and copy all the files in it to this path.

C:\Users\USERNAME\AppData\Local\Microsoft\Edge SxS\Application\105.0.1336.0 <-- ( 105.0.1335.0 will appear for some people. )

After copying it here, it will open without any problems.
Working :thumbs_up:
Fuc..ng Microsoft... link to 1334 not working...

@Milda2000 hello


new download link :)



Thanks READY... :)


I tried to follow your instructions, I downloaded the file, I opened the exe file with winrar, then a 7z file appears, but when I tried to explore it, it directly starts extracting so I can't reach the folder 105.0.1334.0, what am i doing wrong?

After opening the exe file with winrar, it contains the MSEDGE.7z file. When you open this file again with winrar, there is a chrome-bin folder in it and there is a 105.0.1334.0 folder in it. If you paste the files in the 105.0.1334.0 folder directly into the latest version, edge canary opens without any problems.
same here(China)
When I tried to open or exploring the 7z it starts extracting (installing) the file automatically, how can i open the file without extracting?

same here (Windows 10 Pro, Version 21H2, Build 19044.1865).

Latest version of Edge Canary Build on Windows 11 works! (Pro Insider Preview, Version 22H2, Build 25163.1010)

Thank you very much, it worked!

This did work.
There were a few files in the 105.0.1336.0 Folder which was not overwritten by the extracted 105.0.1334.0 files.

I therefore deleted the following files manually.

and the following folder:

The installer folder was not overwritten either, but it included the 105.0.1336.0 installer. I left this one untouched.

True. However, it would still be nice if issues that make Edge non-functional for testers were fixed as soon as possible.
New version 105.0.1337.0
- installed
- i think the problem is now fixed-
Can confirm. Edge Canary self-destroyed this morning.
I ran the Edge Canary Installer and ended up with a working version 105.0.1337.0.
Yes it's good with the last version
We had disabled the crashing feature via an experimental rollout late last week, but unfortunately Edge needs to stay alive long enough to get the experimental update, and when it's crashing on launch like this, it obviously can't. If anybody else is still crashing on launch, let me know and I'll see if there is a command line switch to temporarily disable the feature so you can keep Edge alive.