[Solved] Canary no longer opens

Bronze Contributor



After the latest Canary update, the browser no longer opens

Does anyone have the full .exe of 105.0.1334 ?



59 Replies
Yes same here (Germany)

@tistou Confirmed here, too. Only PWA and InPrivate mode opens, but crash when going to settings.

same here

Wrong path for the Application Folder ?


C:\Program Files (x86)\Microsoft\Edge\Application
C:\Program Files (x86)\Microsoft\Edge Beta\Application
C:\Program Files (x86)\Microsoft\Edge Dev\Application


C:\Users\marti\AppData\Local\Microsoft\Edge\User Data
C:\Users\marti\AppData\Local\Microsoft\Edge Beta\User Data
C:\Users\marti\AppData\Local\Microsoft\Edge Dev\User Data
C:\Users\marti\AppData\Local\Microsoft\Edge SxS\Application
C:\Users\marti\AppData\Local\Microsoft\Edge SxS\User Data

No, it's good ;)


no funktion, I don't know, what exatly must change for Edge Canary.

I have this directorys:


C:\Program Files (x86)\Microsoft\Edge\Application

C:\Program Files (x86)\Microsoft\Edge\EdgeCore

C:\Program Files (x86)\Microsoft\Edge\EdgeUpdate

C:\Program Files (x86)\Microsoft\Edge\EdgeWebView\Application


C:\Users\HP Weber\AppData\Local\Microsoft\Edge\User Data

C:\Users\HP Weber\AppData\Local\Microsoft\Edge\SxS\Application

C:\Users\HP Weber\AppData\Local\Microsoft\Edge\SxS\User Data

And by renaming the Default folder (back up the folder before, to restore it after the test), does it launch ?
which folder you mean?
Users\xxxxxxxx\AppData\Local\Microsoft\Edge SxS\User Data\Default
....\Default "is empty"
Weird, that's where the user profile is
I do not know what to do, which directories are meant :-((
If you haven't used Edge Canary yet, maybe the profile hasn't been created yet (since the latest version won't launch)
Edge Canaray was working fine until the update came today.
Yes, me too.

Same question@tistou 

Hello, as I said, everything went fine until the update, in the end I uninstalled Edge Canary and then reinstalled it.
Until I got the Edge Canary, I was used to it, without Bing and without the news, weather spam, that worked for a while :)
But one thing is still wrong, I have to "kick" several times to start Edge Canary link in the taskbar or desktop shortcut...so there is still something not as it should be...that was before the update too not the case, 1 click and it was good.
Greetings from Germany
same here. sad


I'm not sure but switching Required/Optional Diagnostic Data (in Windows Settings > Privacy > Diagnostics & feedback) seems to enable opening Edge for a few times.


Yet another bug, Services section in settings (edge://settings/privacy) is not displayed.