SharePoint "Open with Explorer"

%3CLINGO-SUB%20id%3D%22lingo-sub-840916%22%20slang%3D%22en-US%22%3ESharePoint%20%22Open%20with%20Explorer%22%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-840916%22%20slang%3D%22en-US%22%3E%3CP%3EHi%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ECan%20we%20expect%20the%20Library%20feature%20%22Open%20with%20Explorer%22%20in%20SharePoint%20to%20be%20available%20in%20the%20new%20Edge%20C%20browser%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThank%20you%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-841471%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20%22Open%20with%20Explorer%22%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-841471%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F404714%22%20target%3D%22_blank%22%3E%40moraise%3C%2FA%3E%2C%20to%20enable%20the%20%22Open%20with%20Explorer%22%20functionality%20you%20need%20to%20run%20the%20page%20in%20IE-Mode.%26nbsp%3B%20This%20is%20because%20that%20feature%20is%20supported%20by%20an%20Active-X%20component.%26nbsp%3B%20You%20can%20find%20out%20more%20about%20how%20to%20set%20up%20IE-Mode%20and%20add%20it%20to%20the%20site%20list%20manager%20here%3A%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2FDeployEdge%2Fedge-ie-mode%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2FDeployEdge%2Fedge-ie-mode%3C%2FA%3E.%26nbsp%3B%20Thanks%20-%20Elliot%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1114379%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20%22Open%20with%20Explorer%22%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1114379%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F239638%22%20target%3D%22_blank%22%3E%40Elliot%20Kirk%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHi%20Elliot%3C%2FP%3E%3CP%3EYou%20are%20correct%20that%20this%20function%20is%20triggered%20by%20an%20ActiveX.%26nbsp%3B%3CBR%20%2F%3EBut%20the%20ActiveX%20isn't%20doing%20much%2C%20imho%20it%20doesn't%20even%20have%20to%20be%20interpreted%2Frun%2C%20it%20would%20be%20good%20enough%20if%20the%20Edge%20Browser%20would%20recognize%20the%20ActiveX%20and%20understand%20what%20the%20User%20of%20the%20Sharepoint%20DocLib%20would%20like%20to%20do.%3C%2FP%3E%3CP%3EIn%20the%20End%2C%20all%20what%20has%20to%20be%20done%20is%20connecting%20the%20Windows%20Explorer%20to%20the%20WebDav%20Path%20of%20the%20Document%20Library.%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fhelp.dreamhost.com%2Fhc%2Fen-us%2Farticles%2F216473357-Accessing-WebDAV-with-Windows%22%20target%3D%22_blank%22%20rel%3D%22noopener%20nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fhelp.dreamhost.com%2Fhc%2Fen-us%2Farticles%2F216473357-Accessing-WebDAV-with-Windows%3C%2FA%3E%3CBR%20%2F%3ESince%20this%20was%20implemented%20into%20Sharepoint%20and%20effort%20was%20done%20to%20implement%20this%20into%20Windows%20itself%2C%20it%20should%20also%20be%20possible%20to%20bridge%20this%20gap%20by%20the%20Edge%20Browser.%3CBR%20%2F%3EGreetings%3CBR%20%2F%3EPhil%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1210978%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20%22Open%20with%20Explorer%22%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1210978%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F239638%22%20target%3D%22_blank%22%3E%40Elliot%20Kirk%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHmm%2C%20we%20are%20using%20the%20IE%20Mode%20for%20our%20%22old%22%20Sharepoint%202013%20environment%3B%20compat-mode%20is%20IE11%20and%20open-in%20is%20IE11%20as%20well.%3C%2FP%3E%3CP%3EBut%20the%20%22Open%20with%20explorer%22%20is%20still%20not%20working%20%3A(%3C%2Fimg%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ECan%20anybody%20confirm%20that%20the%20%22webdav%20function%22%20is%20working%20with%20ie%20mode%3F%3C%2FP%3E%3CP%3EAnd%20if%20so%20share%20his%20configuration%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%20a%20lot%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Occasional Visitor

Hi

 

Can we expect the Library feature "Open with Explorer" in SharePoint to be available in the new Edge C browser?

 

Thank you

3 Replies
Highlighted

Hi @moraise, to enable the "Open with Explorer" functionality you need to run the page in IE-Mode.  This is because that feature is supported by an Active-X component.  You can find out more about how to set up IE-Mode and add it to the site list manager here: https://docs.microsoft.com/en-us/DeployEdge/edge-ie-mode.  Thanks - Elliot

Highlighted

@Elliot Kirk 

Hi Elliot

You are correct that this function is triggered by an ActiveX. 
But the ActiveX isn't doing much, imho it doesn't even have to be interpreted/run, it would be good enough if the Edge Browser would recognize the ActiveX and understand what the User of the Sharepoint DocLib would like to do.

In the End, all what has to be done is connecting the Windows Explorer to the WebDav Path of the Document Library.

https://help.dreamhost.com/hc/en-us/articles/216473357-Accessing-WebDAV-with-Windows
Since this was implemented into Sharepoint and effort was done to implement this into Windows itself, it should also be possible to bridge this gap by the Edge Browser.
Greetings
Phil

Highlighted

@Elliot Kirk 

Hmm, we are using the IE Mode for our "old" Sharepoint 2013 environment; compat-mode is IE11 and open-in is IE11 as well.

But the "Open with explorer" is still not working :(

 

Can anybody confirm that the "webdav function" is working with ie mode?

And if so share his configuration?

 

Thanks a lot