Serious problem using Edge with my bank's internet banking

Regular Contributor

This is all the same in Stable, Dev and Canary. I don't know when it might have started as Edge in Canary and Dev have only very recently gained features I needed to try any extended 'normal' browsing with it.

 

To use my bank's 'internet banking', the user goes to a login page for personal accounts, fills in username and password, clicks, then is taken to a verification page where the user has to enter requested letters/numbers from the user's 'memorable information', clicks, and is then taken to the main accounts page (or usually an ad for some bank service first) .... well, that's what happens when I go there in Firefox. In Edge, not so much.

 

In Edge Stable, Dev and Canary, I go to the login page, fill in username and password (actually autofilled in Firefox and Edge), click, get taken to the  verification page, fill in the requested letters/numbers from my memorable information, click ... and am taken straight back to the initial login page every time, never on to my bank account. I've gone to the site permissions page and tried allowing everything that was set to block even if it didn't look relevant, turned off tracking prevention on the site ... nothing makes any difference, bounced straight back from the verification page to the initial login page. I don't understand the dev tools, but there was something there in the console about something being blocked by the client (which I assume is Edge).

 

The one way I eventually found I CAN get in with Edge is in an InPrivate window. Then I can .log in (although the username and password don't autocomplete, presumably due to no cookie) and go through the verification. BUT I have to go through an additional palaver of an extra authentication of verifying after the normal verification page of waiting up to several minutes for a texted code to then let me set my computer with Edge as a 'trusted device' ... EVERY TIME, because InPrivate doesn't keep the cookie that's set (there's a note in the dialogue to set my computer-with-Edge as a trusted device that I will have to do it again if I delete all cookies, but as this is an InPrivate window that's every use).

 

This is unacceptable. I don't use InPrivate ever. I am the only person with access to my laptop and my home WiFi. If I can't access my bank account with Edge as easily as with Firefox, I'll just keep using Firefox.

1 Reply

Hi,
try disabling "Sign in automatically" from Edge password manager: edge://settings/passwords
then proceed with logging in to your account. when Edge asks to sign in automatically, select no or cancel it, continue signing in manually using the autofill data, see how it goes.

 

also you didn't mention anything about extensions so I assume you've already tried logging in to your account with all of your extensions disabled?