Search engine doesn't work when some websites are open in the tab

%3CLINGO-SUB%20id%3D%22lingo-sub-1059500%22%20slang%3D%22en-US%22%3ESearch%20engine%20doesn't%20work%20when%20some%20websites%20are%20open%20in%20the%20tab%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1059500%22%20slang%3D%22en-US%22%3E%3CP%3EWhen%20I%20have%20a%20Google%20spreadsheets%20open%20in%20the%20tab%20and%20I%20go%20to%20the%20bar%20address%20and%20enter%20the%20key%20of%20a%20custom%20search%20engine%20(example%20map)%20that%20I%20normally%20use%20to%20go%20to%20%22%3CA%20href%3D%22https%3A%2F%2Fwww.google.com%2Fmaps%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fwww.google.com%2Fmaps%3C%2FA%3E%22%20then%20egde%20redirect%20my%20to%20map.com%20and%20not%20%22%3CA%20href%3D%22https%3A%2F%2Fwww.google.com%2Fmaps%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fwww.google.com%2Fmaps%3C%2FA%3E%22.%20Idem%20for%20other%20custom%20search%20engine%20%3A%20mov%20redirects%20to%20mov.com%20and%20not%20my%20custom%20search%20engine...%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAll%20extensions%20and%20user%20scripts%20are%20disabled.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Eedge%20version%20%3A%20Version%2080.0.355.1%20(Official%20build)%20dev%20(64-bit)%3C%2FP%3E%3CDIV%20class%3D%22c01269%22%3E%26nbsp%3B%3C%2FDIV%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1059795%22%20slang%3D%22en-US%22%3ERe%3A%20Search%20engine%20doesn't%20work%20when%20some%20websites%20are%20open%20in%20the%20tab%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1059795%22%20slang%3D%22en-US%22%3EHi%2C%3CBR%20%2F%3Eare%20you%20using%20any%20flags%20that%20are%20changing%20the%20omnibox's%20behavior%3F%3CBR%20%2F%3E%3CBR%20%2F%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1067142%22%20slang%3D%22en-US%22%3ERe%3A%20Search%20engine%20doesn't%20work%20when%20some%20websites%20are%20open%20in%20the%20tab%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1067142%22%20slang%3D%22en-US%22%3E%3CP%3ESorry%20for%20the%20delay%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310193%22%20target%3D%22_blank%22%3E%40HotCakeX%3C%2FA%3E%26nbsp%3B.%3C%2FP%3E%3CP%3EI%20checked%26nbsp%3B%3CA%20href%3D%22edge%3A%2F%2Fflags%2F%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Eedge%3A%2F%2Fflags%2F%3C%2FA%3E%26nbsp%3Band%20search%20for%26nbsp%3B%3CSPAN%3Eomnibox%20and%20everything%20is%20set%20to%20default%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1067198%22%20slang%3D%22en-US%22%3ERe%3A%20Search%20engine%20doesn't%20work%20when%20some%20websites%20are%20open%20in%20the%20tab%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1067198%22%20slang%3D%22en-US%22%3EOh%20it's%20okay%20%3A)%3C%2Fimg%3E%3CBR%20%2F%3Ewell%20it's%20just%20Edge%20then%20having%20this%20bug%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1073363%22%20slang%3D%22en-US%22%3ERe%3A%20Search%20engine%20doesn't%20work%20when%20some%20websites%20are%20open%20in%20the%20tab%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1073363%22%20slang%3D%22en-US%22%3E%3CP%3EDo%20you%20know%20how%20this%20can%20be%20fixed%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1073490%22%20slang%3D%22en-US%22%3ERe%3A%20Search%20engine%20doesn't%20work%20when%20some%20websites%20are%20open%20in%20the%20tab%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1073490%22%20slang%3D%22en-US%22%3Ewhat%20happens%20when%20you%20paste%20%22%20%3CA%20href%3D%22https%3A%2F%2Fwww.google.com%2Fmaps%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fwww.google.com%2Fmaps%3C%2FA%3E%20%22%20right%20into%20your%20browser's%20address%20bar%3F%3CBR%20%2F%3E%3CBR%20%2F%3EAlso%20you%20can%20delete%20past%20autocomplete%20entries%20from%20the%20omnibox%20by%20highlighting%20them%20(using%20up%2Fdown%20arrow%20keys%20on%20keyboard)%20and%20then%20pressing%20this%20shortcut%3A%20SHIFT%20%2B%20DELETE%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1078533%22%20slang%3D%22en-US%22%3ERe%3A%20Search%20engine%20doesn't%20work%20when%20some%20websites%20are%20open%20in%20the%20tab%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1078533%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310193%22%20target%3D%22_blank%22%3E%40HotCakeX%3C%2FA%3E%26nbsp%3B%20When%20I%20paste%26nbsp%3B%3CSPAN%3E%22%26nbsp%3B%3C%2FSPAN%3E%3CA%20href%3D%22https%3A%2F%2Fwww.google.com%2Fmaps%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fwww.google.com%2Fmaps%3C%2FA%3E%3CSPAN%3E%26nbsp%3B%22%20right%20into%20my%20browser's%20address%20bar%20then%20I%20am%20redirected%20to%26nbsp%3B%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fwww.google.com%2Fmaps%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fwww.google.com%2Fmaps%3C%2FA%3E%26nbsp%3B.%26nbsp%3B%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3EThe%20problem%20is%20not%20in%20the%20redirection%20of%20address%20but%20in%20how%20my%20custom%20search%20engine%20are%20interpreted.%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Contributor

When I have a Google spreadsheets open in the tab and I go to the bar address and enter the key of a custom search engine (example map) that I normally use to go to "https://www.google.com/maps" then egde redirect my to map.com and not "https://www.google.com/maps". Idem for other custom search engine : mov redirects to mov.com and not my custom search engine...

 

All extensions and user scripts are disabled.

 

edge version : Version 80.0.355.1 (Official build) dev (64-bit)

 
6 Replies
Highlighted
Hi,
are you using any flags that are changing the omnibox's behavior?

Highlighted

Sorry for the delay @HotCakeX .

I checked edge://flags/ and search for omnibox and everything is set to default

Highlighted
Oh it's okay :)
well it's just Edge then having this bug
Highlighted

Do you know how this can be fixed?

Highlighted
what happens when you paste " https://www.google.com/maps " right into your browser's address bar?

Also you can delete past autocomplete entries from the omnibox by highlighting them (using up/down arrow keys on keyboard) and then pressing this shortcut: SHIFT + DELETE
Highlighted

@HotCakeX  When I paste https://www.google.com/maps " right into my browser's address bar then I am redirected to  https://www.google.com/maps . 

The problem is not in the redirection of address but in how my custom search engine are interpreted.