Read Aloud not working since a few weeks

Copper Contributor

Hello everyone,


I have been using Edge for pdf-files since the beginning and also the read aloud feature. However since a few updates (don't know which started it) read aloud doesn't work anymore. It is stuck forever in the loading animation (visible in the picture). This bug is file-independent as I have tried multiple and all work fine using the stable Edge build.




10 Replies


Firstly, make sure your Microsoft Edge is update and if problem persist, go to top right corner of Microsoft Edge and click on ...->Help and feedback->Send feedback and share your issue.



I just tried using Read Aloud online voices on PDFs on Edge Version 87.0.664.60 (Official build) (64-bit) stable, it worked fine, so the problem is not universal, you could take some troubleshooting steps yourself to see if you can get it working again.


  1. you can try disabling your extensions in case one of them is causing conflict edge://extensions/
  2. you can reset your custom flags if you've set any of them before: edge://flags/
  3. you can try resetting Edge settings (make sure sync is enabled): edge://settings/reset


by the way, is your Edge/device being controlled by an organization? if that's the case they might have disabled it.


if none of them fixed the problem,

 you can send a feedback using the feedback button on Edge or shortcuts (alt + shift + i), and from the feedback window navigate to Attachments => recreate my problem => start recording, and then you can start read aloud on PDF, make sure it doesn't work, and then stop recording and send your feedback.


hope that helps

@Reza_Ameri-Archived Thanks for your fast reply, I had already done that a week before writing this post.

@HotCakeX thank you for your possible solutions. However I have tried them all but the problem still persists. In the stable build the feature works on both my devices. I forgot to mention in my original post that the problem is in the dev branch builds. In those builds the bug has been the same through multiple updates and both devices I have. I will send feedback again using the recreation of the problem


In this case, sending feedback using Feedback option would be the best way as you did , so Microsoft Edge team would be able to investigate the issue.


Well try sending feedback using feedback button on Edge or shortcuts Alt + shift + i, from the mini window choose attachments and then recreate my problem, when it's recording try to reproduce the issue and hopefully it'll catch enough data to send with your feedback.

if you are unable to use it (due to organization policies) you can use the online form:




Hi, we have a similar problem here in Sweden.

Edge is working - reading aloud when the PDF consists of at least TWO pages.

If the .pdf is only ONE page the reading aloud is not working. It is stuck forever in the loading animation.


We have the latest version Version 89.0.774.57 (Officiell version) (64 bitar).

It has worked before.



please use the feedback button on Edge to report it.

@Sambuccus I'm also facing same problem in both of my computer, It was working fine in older version

Hi nvnsaroj,
I have reported this problem to Microsoft after advise from HotCakeX.
The problem still exists.
Now I have 89.0.774.68 (Officiell version) (64 bitar).