"Start new collection" does nothing

%3CLINGO-SUB%20id%3D%22lingo-sub-1477858%22%20slang%3D%22en-US%22%3E%22Start%20new%20collection%22%20does%20nothing%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1477858%22%20slang%3D%22en-US%22%3E%3CP%3EI%20just%20tried%20using%20Collections%20for%20the%20first%20time%20today.%20I%20can%20open%20the%20Collections%20pane%20fine%20but%20nothing%20I%20do%20to%20add%20a%20tab%2Fpage%20works.%20%22Start%20new%20collection%22%20does%20nothing.%20%22Add%20all%20tabs%20to%20new%20collection%22%20does%20nothing.%20%22Add%20page%20to%20collections%22%20does%20nothing.%20About%20says%20I%20am%20running%20the%20latest%20version%20...%26nbsp%3B%3C%2FP%3E%3CDIV%20class%3D%22c01176%20c01183%22%3E%3CDIV%20class%3D%22c01178%22%3E%3CH2%20id%3D%22toc-hId--1323897896%22%20id%3D%22toc-hId--1323897835%22%20id%3D%22toc-hId--1323897835%22%20id%3D%22toc-hId--1323897835%22%3EAbout%3C%2FH2%3E%3C%2FDIV%3E%3C%2FDIV%3E%3CDIV%20class%3D%22c01157%22%3E%3CDIV%20class%3D%22c01154%22%3E%3CSPAN%20class%3D%22c01156%22%3EMicrosoft%20Edge%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%20class%3D%22c01160%20c01185%22%3E%3CDIV%20class%3D%22c01189%22%3E%3CSPAN%20class%3D%22c01191%22%3EMicrosoft%20Edge%20is%20up%20to%20date.%3C%2FSPAN%3E%3C%2FDIV%3E%3CDIV%20class%3D%22c01189%22%3E%3CSPAN%20class%3D%22c01192%22%3EVersion%2084.0.522.20%20(Official%20build)%20beta%20(64-bit)%3C%2FSPAN%3E%3C%2FDIV%3E%3C%2FDIV%3E%3C%2FDIV%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1478696%22%20slang%3D%22en-US%22%3ERe%3A%20%22Start%20new%20collection%22%20does%20nothing%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1478696%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F705073%22%20target%3D%22_blank%22%3E%40MWETulsa%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHi%20there%2C%20you%20are%20welcome%20to%20the%20Microsoft%20Edge%20Insider%20Community!%3C%2FP%3E%3CP%3EI%20would%20recommend%20you%20to%20also%20send%20this%20feedback%20through%20the%20in-app%20feedback%20tool%20(Alt%2BShift%2BI)%20in%20Microsoft%20Edge%20with%20the%20diagnostics%20attached%20which%20will%20help%20the%20Microsoft%20Edge%20team%20to%20resolve%20your%20issue.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1478726%22%20slang%3D%22en-US%22%3ERe%3A%20%22Start%20new%20collection%22%20does%20nothing%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1478726%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F537238%22%20target%3D%22_blank%22%3E%40theshaunsaw%3C%2FA%3E%26nbsp%3Bok%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
New Contributor

I just tried using Collections for the first time today. I can open the Collections pane fine but nothing I do to add a tab/page works. "Start new collection" does nothing. "Add all tabs to new collection" does nothing. "Add page to collections" does nothing. About says I am running the latest version ... 

About

Microsoft Edge
Microsoft Edge is up to date.
Version 84.0.522.20 (Official build) beta (64-bit)
2 Replies
Highlighted

@MWETulsa 

Hi there, you are welcome to the Microsoft Edge Insider Community!

I would recommend you to also send this feedback through the in-app feedback tool (Alt+Shift+I) in Microsoft Edge with the diagnostics attached which will help the Microsoft Edge team to resolve your issue.

Highlighted