"Save as" in embedded PDF downloads a 0 KB file

Copper Contributor

I've got an embedded PDF Window, where I see the PDF correctly.


But when I use "save as..", it downloads a 0 KB PDF file.


This happens only in Edge. I tried it with Firefox and Chrome, and there it downloads the PDF without problem.


The funny thing is that this website gives me the option to download the PDF directly without showing it embedded in the Window. And that download works perfect. Only the download of the embedded view doesn't work.


Any ideas?

6 Replies
Link to PDF so we can try it?
which Edge version?

@HotCakeXit's an intranet site, there's no external access.


I'm developer of this site, and the generation and download of the PDF has worked always OK in other browsers, but we've received a call from a client complaining that the download doesn't work on Edge.


Edge version: 89.0.774.75

best response confirmed by Xithias (Copper Contributor)
if you haven't already, please use the feedback button on Edge to report it to Edge developers or guide them to do it
I've done it, but for now, not answer.

I don't know if this can help: the MIME type I set for the embedded resource is "application/pdf".

If the resource is not embedded, then I use "application/download".
OK, the version 90.0.818.39 fixes the problem. I suppose, they have read my feedback :)
That's great ^^