Home

pwahelper.exe missing

%3CLINGO-SUB%20id%3D%22lingo-sub-1088245%22%20slang%3D%22en-US%22%3Epwahelper.exe%20missing%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1088245%22%20slang%3D%22en-US%22%3E%3CP%3EFor%20some%20reason%2C%20something%20has%20calused%20pwahelper.exe%20to%20become%20missing%20or%20corrupted%2C%20resulting%20in%20an%20error%20on%20PWA%20installation.%20Weirdly%2C%20the%20PWA%20then%20opens%20as%20expected%20but%20Edge%20does%20not%20recognize%20it%20as%20being%20installed%2C%20and%20I%20have%20to%20use%20the%20system%20to%20uninstall%20it.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1088305%22%20slang%3D%22en-US%22%3ERe%3A%20pwahelper.exe%20missing%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1088305%22%20slang%3D%22en-US%22%3EHi%2C%3CBR%20%2F%3EWhich%20Edge%20insider%20channel%3F%20have%20you%20tried%20reinstalling%20your%20browser%3F%20that%20should%20restore%20the%20missing%20file%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1090962%22%20slang%3D%22en-US%22%3ERe%3A%20pwahelper.exe%20missing%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1090962%22%20slang%3D%22en-US%22%3ECanary%20channel.%20And%20yes%2C%20a%20full%20uninstall%20%2F%20reinstall%20restored%20the%20missing%20file%20last%20time%20I%20had%20this%20issue%20a%20few%20months%20ago.%3CBR%20%2F%3E%3CBR%20%2F%3EBut%20I%20would%20like%20to%20have%20the%20issue%20that%20makes%20the%20file%20corrupted%20be%20fixed%20in%20the%20first%20place%20%3A)%3C%2Fimg%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1091084%22%20slang%3D%22en-US%22%3ERe%3A%20pwahelper.exe%20missing%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1091084%22%20slang%3D%22en-US%22%3ESounds%20like%20first%20we%20have%20to%20find%20out%20what%20even%20causes%20that%20file%20to%20get%20corrupted%20every%20few%20months%20%3A)%3C%2Fimg%3E%3C%2FLINGO-BODY%3E
Highlighted
19lmyers
Contributor

For some reason, something has calused pwahelper.exe to become missing or corrupted, resulting in an error on PWA installation. Weirdly, the PWA then opens as expected but Edge does not recognize it as being installed, and I have to use the system to uninstall it.

3 Replies
Highlighted
Hi,
Which Edge insider channel? have you tried reinstalling your browser? that should restore the missing file
Highlighted
Canary channel. And yes, a full uninstall / reinstall restored the missing file last time I had this issue a few months ago.

But I would like to have the issue that makes the file corrupted be fixed in the first place :)
Highlighted
Sounds like first we have to find out what even causes that file to get corrupted every few months :)
Related Conversations