Problem with an e-commerce site

Highlighted
Super Contributor

Hello

 

Since 2, 3 versions of Edge Canary, I have a problem with a French e-commerce site (www.docmicro.com)
I cannot finalize my order, when I click on the button, nothing happens (no problem with any other browser, eg Google Chrome)

If I inspect this page, I have warnings about cookies, but I have no idea how to interpret this

 

Capture.PNG

 

Thanks

17 Replies
Highlighted
you can read more about cross-site cookies here:
https://web.dev/samesite-cookies-explained/

does the website work in stable version of Edge?
Highlighted

@HotCakeX 

 

I guess so, since the problem has appeared since a few versions of Canary

Highlighted
The site is probably not compatible with the latest changes in Chromium or Edge 82.
Highlighted

@HotCakeX 

 

It's good with the last Chrome version

It's Edge, the "problem"

Highlighted

@tistou 


@tistou wrote:

@HotCakeX 

 

It's good with the last Chrome version

It's Edge, the "problem"


Which version of Chrome does it work on?

Highlighted

@HotCakeX 

 

80.0.3987.132 I believe

Highlighted

@tistou 


@tistou wrote:

@HotCakeX 

 

80.0.3987.132 I believe


well, like I said, the site is probably not compatible with the latest changes in Chromium or Edge 82.

latest Chromium (the source of Edge) and Edge 82 which is canary.

Highlighted

@HotCakeX 

 

Ok, it's good with stable version (Chrome and Edge), and not good with the last "Edge beta" (good with 82.0.3xx)

 

And it's good with the last beta Chrome (81.0.4044.43)

Too bad, I'll use Chrome then, if it stays like that

Highlighted
Canary receives changes fast but sites still have time, more than 1 month, to make themselves compatible with the changes once they are in stable channel.
Highlighted

@HotCakeX 

 

I contacted the site, I am the only one to have informed them of this problem for 1 week (on approximately 2000 orders placed on their site without problem)

 

I have to be the only one using Edge Canary and so they won't do anything

And by the time the stable Edge goes into 82, it's not right away :)

Highlighted
it might be only Edge canary 82 having this problem or maybe Chrome Canary 82 has the same problem too.
Highlighted

@HotCakeX 

 

I'll test with Chrome Canary 82, to see

Highlighted
Sounds good
Highlighted

@HotCakeX 

 

Tested with Chrome Canary Version : 82.0.4078.0 (Build officiel) canary (64 bits)

 

And no problem with this site

Besides the bugs that I "reported" are not present in Chrome Canary

The problem is only Edge Canary


And Chrome Canary seems faster, I hope MS will work well on Edge :smile:

Highlighted

@tistou Thanks for sharing those details. If you haven't yet, can you please submit this through the browser? Our team would love to take a more detailed look at the diagnostic logs.

 

Fawkes (they/them)
Project & Community Manager - Microsoft Edge

Highlighted

@fawkes 

 

Ok I do that ;)

Highlighted

@fawkes 

 

It's good with Canary .445 :smile:

 

If the indicated bugs could be resolved as quickly :lol: