Problem after latest update to Edge version 89.0.774.48

Copper Contributor

We are having major problems after latest update to Edge version 89.0.774.48. Edge starts multiple processes and the program hangs and is not responding, the processes are not being closed on command.

The problem appears in Edge Stable and Edge Beta, in Windows 10 version 1909 and 20H2.




13 Replies
if you haven't already, please use the feedback button on Edge to report this performance issue.
shortcut: Alt + Shift + i

@HotCakeX As the program not is responding, there is no possiblilty to perform this action

Please try adding this to the end of target of your Edge shortcut "--profile-directory=test"

make sure Edge is closed first. if you can't force close it through task manager. in task manager, go to startup tab and disable Edge startup task, then restart computer.

after that, right-click on Edge shortcut on desktop and choose properties. then select "Shortcut" tab and in the Target text field, at the end, add that line "--profile-directory=test"

so your Target should look like this:

"C:\Program Files (x86)\Microsoft\Edge\Application\msedge.exe" --profile-directory=test

let me know how it goes and if Edge can start and work properly.

We have tested this and the issue is still the same :(

@camilla67 We are having the same exact issue.  We deployed 89.0.774.48 in our org and reports started flooding in with the same issue reported here.  Edge will not open at all.  I had to roll us back to 89.0.774.45.  See attached clip of the issue.


You should run it in the clean boot and see if problem persist?

Take a look at How to perform a clean boot in Windows (

If you manage to open the Microsoft Edge, then report this issue through the feedback option.

best response confirmed by camilla67 (Copper Contributor)
the problem is related to the use of ue-v
if I disable the ue-v profile of Edge or stop the ue-v Edge service opens without any problem.
This problem needs to be fixed by Microsoft. We use ue-v to save the bookmark file

Stopping the ue-v service solves the problem, also to unregister the ue-v template for Edge solves the problem keeping the ue-v service running

Command for unregistering the ue-v template named Edge is:

Get-UevTemplate -Application "Edge" | Unregister-UevTemplate


Problem is really solved, when you unregister the Edge-template from UEV. However I would like to know, when Microsoft is going to address this issue and when they publish a hotfix.
We have a support request for this with Microsoft, their response is:

Edge v89.0.774.48 has been reported to encounter problems when UE-V is used on a machine OR with some antivirus software.
Our Product Group is actively working to find a cause and to mitigate it.

As a workaround you can downgrade to v89.0.774.45.
Same Problem here. Version 89.0.774.50 works as expected.
Hi folks, just confirming that version 89.0.774.50 should resolve this issue for you!

Carbon Black provided some additional information on their site -

If you're still running into this on version 89.0.774.50, please let me know so I can pass your information on to the team! =)

@Alexandra-R Can confirm upgrading to 89.0.774.50 resolved the issue for us.