Pages not loading...

Not applicable



I am having the same issue reported by one user today, in this link:


Web pages don't load in Canary version .254


Are you also experiencing this issue?


11 Replies
Same here.

Hi @JohnGalt 


and yesterday was this version working for you?


I installed canary .254 yesterday and all was fine until today, everything working well... this issue started today... 


Well, let's wait for more comments.... 



I am using Version (Official build) canary (64-bit) and have had no issues with any web page(s).


Even the page John had issues with loads -



FWIW I am running Windows 10 version 1903 build 18362.295


And, I am using 7 extensions all download and installed from the Google Chrome Store.


I will await the next Canary update. If the problem persist I will reinstall it
best response




Follow these steps:

  1. Go to C:\Users\USERNAME\AppData\Local\Microsoft\Edge SxS\Application  (replace USERNAME with your own Windows username)
  2. open a CMD window in that directory. you can do it by typing "CMD" in the windows explorer's address bar and pressing Enter.Annotation 2019-08-23 171050.png
  3. then type in this command: msedge.exe --user-data-dir=c:\foo
  4. if everything goes right, it should load a brand new Edge browser window for you, which means your Edge browser files are not corrupted or anything, load some websites and see if they work.
  5. if they do then you can go ahead and close it.
  6. Go here and delete the folder called "User Data" C:\Users\USERNAME\AppData\Local\Microsoft\Edge SxS  (again replace the USER name with your own)
  7. now open your Edge canary browser normally and report back what happened. hope that helps.

p.s: before deleting the User Data folder, you gotta know that it's gonna delete your favorites, passwords etc. you don't have to worry about this if you had enabled cloud sync.


Thanks @HotCakeX 

It worked


Don't forget to delete the folder c:\foo

Any suggestions for the same problem on the Mac OS X channel?
I've never worked with Mac before but the idea is to find the install location of Edge canary and delete the User Data folder. in Windows you could use task manager to open the folder of any running program, maybe there is something similar in Mac.

@HotCakeX sure, just basically blow away the personal settings. 


For other Mac users, here's the path to the personal settings: /Users/<username>/Library/Application Support/Microsoft Edge Canary/ Put it in the trash and carry on. 


@HotCakeX since the user data is corrupt, my hunch is waiting for another build won't fix the problem. What do you think?



I have the same issue. Last night, I fixed it by uninstalling with delete browser data and then reinstalling, but then I had to reconfigure everything. That worked all day today until about an hour ago.


Today, I tried this solution from Scott Hanselman:


C:\Users\USERNAME\AppData\Local\Microsoft\Edge SxS and delete all the "Network Persistent State" files


Which worked, but only lasted 20 minutes and then when I tried this again, did not fix it.


I'm not sure..maybe, new update was just released: Version

it's good though that it happened when most of the cloud sync functions are enabled by default.