Outlook Links Wont open in Edge Chromium Beta

Occasional Contributor

If i set the default browser to anything but Edge Beta, the links open fine from Outlook emails.  If i set it to Edge Beta, i get a message that says, "Something unexpected went wrong with this URL: (URL i clicked) Access  is denied"  Why would access be denied.

20 Replies
does the message appear in the browser or outlook?
also, is it the outlook that's a UWP app or the one that's part of the Office package?

@HotCakeX Hello, thanks for the quick response. We are using Outlook for Office 365 (monthly channel). The message doesn't pop up in either Outlook or Edge (Beta) it pops up on the bottom right as a Windows 10 message. Although it does say Microsoft Outlook, so it may be coming from Outlook.


Thanks for the additional info,
yes it appears that it's coming from the Outlook program but maybe it's somehow related to the Edge insider too (through some group policy settings if you're in a work environment),
can you try a few things? such as making sure you're using a Windows account with Admin rights, and also trying the same thing with Edge Dev and Canary to see whether it's a universal problem or only related to Beta channel

@HotCakeX I manage the GPO's for our browsers and Office. We have not set anything for this type of action, unless its somewhere in the RS baselines. That being said, it works fine from all other browsers (IE, Chrome, Firefox and Edge "old version").

My account is an admin on this system.

I now have all 3, (Beta, Dev & Can) installed.  Funny though, it works fine in Dev and Can, just not in Beta. I set the default browser to Can, Works. I set the default browser to Dev, Works. I set it back to Beta, still doesn't work.  I wonder what the difference is.



@HotCakeXEDIT: I was wrong... after uninstalling and reinstalling Beta, even though it showed as the default browser, i dont think it actually was.  Made sure it was the default browser, and its failing.

Good job, so now we know that it's only happening in Beta, must be a bug in it. Outlook and other stuff are exonerated ^^
you can try reporting this Bug using the smiley feedback button too in case developers miss this thread, it will be delivered straight to them

The problem seems to be back these days  in Version 79.0.309.30 - so it might be related to Outlook (1910, 12130.20272) as Edge Beta hasn't changed?

@HotCakeX - I am also facing this issue on my machines as well. I am currently on Edge Beta version 79.0.309.43. 


This error only happens from Outlook 365 (Verison 1911, 12228.20332 CTR) and not from any other applications on the machine. This issue doesn't happen if I change my browser to anything apart from Edge beta. Chrome, IE and old Edge as default browser all work perfectly fine on the same setup.


Another thing I have observed is that it happens only on my machines joined to Azure Active Directory. On my home machine, the same setup with Outlook and Edge Beta works perfectly fine.


Quick update on my post, just installed Edge dev on my machine and it seems the issue is resolved in build 80.0.345.0 on dev channel.


So something is different between dev and beta channels which is affecting this particular behavior.

@ankitsaraf-uipath Our machines are Azure-AD joined as well. Do you happen to use Microsoft Defender ATP? 

@shinebar - Is there a quick way I can check on that directly from my machine? We do use Defender on our machines, but not sure if ATP is being specifically used. I will have to reach out to our company admins to check that.

Your findings are good! it means whatever change that exist in the Dev channel will eventually be shipped to the Beta channel, so you will be able to use it :)

@ankitsaraf-uipath Good question. I'll check that tomorrow morning in the office - I think from the users perspective there is just a changed registry key. Actually I was quite suprised that there was no visible change or even installation when we enabled ATP.

@shinebar I found a folder called "C:\ProgramData\Microsoft\Windows Defender Advanced Threat Protection" on my machine with bunch of other folders in it which I can't access by default. So it seems, yes our organization is using ATP.

@ankitsaraf-uipath okay, that seems to be an evidence. Can you please check if ATP is running? (sorry for german)




I checked the ATP-Console and there is no indication of a problem with Edge.


Have you tried more recent versions of Edge like Dev and canary?

@HotCakeX  Edge Dev is working. Actually we never had a problem with Edge Dev but two times (with the first Beta ever and with the current version) with Edge Beta. I hope that this bug won't make it into the final.

Soon beta channel should be replaced with version 80 and version 79, if aimed to be the first version of stable channel, to go for heavy bug checking

@HotCakeX Another update on this. My Windows defender started prompting this now every time a link fails to open. So something weird happening with Defender attack surface reduction -