onblur function does not work in new edge

%3CLINGO-SUB%20id%3D%22lingo-sub-1174959%22%20slang%3D%22en-US%22%3Eonblur%20function%20does%20not%20work%20in%20new%20edge%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1174959%22%20slang%3D%22en-US%22%3E%3CDIV%3EI%20made%20some%20function%20in%20JavaScript.%20It%20is%20called%20on%20onBlur%20event.%20It%20works%20fine%2C%20but%20when%20alert%20is%20shown%20it%20does%20not%20want%20to%20remove.%20I%20click%20ok%2C%20but%20nothing%20happens.%3C%2FDIV%3E%3CDIV%3EHere%20is%20what%20I%20found%20in%20console.%3C%2FDIV%3E%3CDIV%3E%26nbsp%3B%3C%2FDIV%3E%3CDIV%20class%3D%22x-hidden-focus%22%3Euser_password_forgot_view.php%3A1%20%5BDOM%5D%20Input%20elements%20should%20have%20autocomplete%20attributes%20(suggested%3A%20%22new-password%22)%3A%20(More%20info%3A%20%3CA%20href%3D%22https%3A%2F%2Fgoo.gl%2F9p2vKq%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fgoo.gl%2F9p2vKq%3C%2FA%3E)%3C%2FDIV%3E%3CDIV%3E%5BViolation%5D%20'blur'%20handler%20took%20%3CN%3Ems%3C%2FN%3E%3C%2FDIV%3E%3CDIV%3Euser_password_forgot_view.php%3A21%20%5BViolation%5D%20'blur'%20handler%20took%201248ms%3C%2FDIV%3E%3CDIV%3E%26nbsp%3B%3C%2FDIV%3E%3CDIV%3EIt%20works%20on%20any%20other%20event%20except%20onBlur.%20How%20can%20I%20fix%20it%3F%3C%2FDIV%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1175428%22%20slang%3D%22en-US%22%3ERe%3A%20onblur%20function%20does%20not%20work%20in%20new%20edge%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1175428%22%20slang%3D%22en-US%22%3EWhich%20Edge%20channel%2Fversion%3F%3CBR%20%2F%3E%3CBR%20%2F%3Ehave%20you%20tried%20%3CA%20href%3D%22https%3A%2F%2Fstackoverflow.com%2F%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fstackoverflow.com%2F%3C%2FA%3E%20%3F%3C%2FLINGO-BODY%3E
Occasional Visitor
I made some function in JavaScript. It is called on onBlur event. It works fine, but when alert is shown it does not want to remove. I click ok, but nothing happens.
Here is what I found in console.
 
user_password_forgot_view.php:1 [DOM] Input elements should have autocomplete attributes (suggested: "new-password"): (More info: https://goo.gl/9p2vKq)
[Violation] 'blur' handler took <N>ms
user_password_forgot_view.php:21 [Violation] 'blur' handler took 1248ms
 
It works on any other event except onBlur. How can I fix it?
1 Reply
Which Edge channel/version?

have you tried https://stackoverflow.com/ ?