Mute tab button doesn't work when I have multiple tabs open. This needs a fix.

%3CLINGO-SUB%20id%3D%22%5C%26quot%3Blingo-sub-3134329%5C%26quot%3B%22%20slang%3D%22%5C%26quot%3Ben-US%5C%26quot%3B%22%3EMute%20tab%20button%20doesn't%20work%20when%20I%20have%20multiple%20tabs%20open.%20This%20needs%20a%20fix.%26lt%3B%5C%2Flingo-sub%26gt%3B%3CLINGO-BODY%20id%3D%22%5C%26quot%3Blingo-body-3134329%5C%26quot%3B%22%20slang%3D%22%5C%26quot%3Ben-US%5C%26quot%3B%22%3E%3CP%3EBeing%20able%20to%20mute%20individual%20tabs%20with%20the%20click%20of%20a%20button%20is%20a%20great%20feature%20and%20it's%20why%20I%20use%20Edge%20over%20Chrome.%20However%2C%20when%20I%20have%20a%20certain%20amount%20of%20tabs%20open-about%2012%20or%20so-I'm%20suddenly%20unable%20to%20click%20the%20speaker%20icon%20to%20mute%20a%20tab%20I'm%20not%20active%20on.%20I%20can%20hover%20over%20the%20speaker%20icon%20but%20instead%20of%20muting%20the%20tab%2C%20it%20forces%20me%20to%20first%20click%20on%20the%20tab%20for%20it%20to%20become%20active%2C%20THEN%20I%20can%20mute%20it.%26nbsp%3B%26lt%3B%5C%2FP%26gt%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%26lt%3B%5C%2FP%26gt%3B%3C%2FP%3E%3CP%3EThis%20defeats%20the%20entire%20purpose%20and%20is%20a%20major%20annoyance%20for%20people%20who%20frequently%20use%20the%20feature%20to%20mute%20other%20tabs.%20Please%20fix%20this!%20If%20there's%20another%20channel%20I%20can%20contact%20the%20devs%20through%20to%20get%20this%20through%20more%20urgently%2C%20please%20let%20me%20know.%26lt%3B%5C%2FP%26gt%3B%26lt%3B%5C%2Flingo-body%26gt%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3C%2FLINGO-SUB%3E%3CLINGO-SUB%20id%3D%22lingo-sub-3134329%22%20slang%3D%22en-US%22%3EMute%20tab%20button%20doesn't%20work%20when%20I%20have%20multiple%20tabs%20open.%20This%20needs%20a%20fix.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-3134329%22%20slang%3D%22en-US%22%3E%3CP%3EBeing%20able%20to%20mute%20individual%20tabs%20with%20the%20click%20of%20a%20button%20is%20a%20great%20feature%20and%20it's%20why%20I%20use%20Edge%20over%20Chrome.%20However%2C%20when%20I%20have%20a%20certain%20amount%20of%20tabs%20open-about%2012%20or%20so-I'm%20suddenly%20unable%20to%20click%20the%20speaker%20icon%20to%20mute%20a%20tab%20I'm%20not%20active%20on.%20I%20can%20hover%20over%20the%20speaker%20icon%20but%20instead%20of%20muting%20the%20tab%2C%20it%20forces%20me%20to%20first%20click%20on%20the%20tab%20for%20it%20to%20become%20active%2C%20THEN%20I%20can%20mute%20it.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThis%20defeats%20the%20entire%20purpose%20and%20is%20a%20major%20annoyance%20for%20people%20who%20frequently%20use%20the%20feature%20to%20mute%20other%20tabs.%20Please%20fix%20this!%20If%20there's%20another%20channel%20I%20can%20contact%20the%20devs%20through%20to%20get%20this%20through%20more%20urgently%2C%20please%20let%20me%20know.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Contributor

Being able to mute individual tabs with the click of a button is a great feature and it's why I use Edge over Chrome. However, when I have a certain amount of tabs open-about 12 or so-I'm suddenly unable to click the speaker icon to mute a tab I'm not active on. I can hover over the speaker icon but instead of muting the tab, it forces me to first click on the tab for it to become active, THEN I can mute it. 

 

This defeats the entire purpose and is a major annoyance for people who frequently use the feature to mute other tabs. Please fix this! If there's another channel I can contact the devs through to get this through more urgently, please let me know.

4 Replies

It seems that tab width must be greater than or equal to 126 pixel on my pc. When tab width is lesser than 126, even though speaker icon is fully visible, it doesn't work at all if the tab is inactive.
For a workaround against this bug, you could try command-line option. (this works for me but may not work for all)
--enable-features=ScrollableTabStrip:minTabWidth/126

 

Or right-click on the tab, select 'Mute tab' from context-menu.

Yes, it seems like it's definitely a bug. The speaker icon is fully visible but I can't click it at all. Having to right click first defeats the whole purpose of being able to conveniently and quickly mute other tabs with a single click, and that command line didn't work. I hope the devs read this, it shouldn't be difficult to fix. The whole reason I moved from Chrome to Edge was for this feature and it doesn't even work properly.
Bump. This desperately needs to be fixed.
Any word from the devs? I hate to have to switch browsers, other than this (Very critical) issue, Edge is great.