MS Edge Enterprise Account Syncing

Occasional Contributor

It seems it is now enabled for me in Dev channel, but it is showing that "sync has been disabled by the administrator." This is a domain-joined PC. Is this setting looking at the "Sync your settings" area in windows 10 that gets disabled by default if it is a domain-joined PC or is this a group policy somewhere else that I cannot find?




Transport StateDisabled
Disable Reasons

Enterprise policy, Waiting for sync url, Waiting for access token


Actionable Error

38 Replies

@Jordan Paris I am interested in this as well.  Since the switch to the Chromium Engine, we have been greatly interested in switching to Edge specifically for the account sync.

best response confirmed by Jordan Paris (Occasional Contributor)

@Jordan Paris  So it appears that the issue is that it requires AD Premium, in particular - Enterprise State Roaming. I had two tenants, one with, one without. One worked, one didn't. I lit up AD Premium on the onr that didn't and after a little while, I was able to get it going. 

Yep! I saw some posts mentioning that and I turned it on for myself to test and it started syncing as expected!

@Jordan Paris Sync is currently available only for AAD premium accounts. We are exploring ways to improve experience for other AAD SKUs. Thanks for your feedback.

@akhator Thank you.  Any likelihood it will be made available to those with Office 365 subscriptions?

@Jordan Paris In our environment it's working in the Edge Beta release, but not in the Edge Dev or Canary release. I have made no changes to our accounts. We have MS365, so AAD Premium is included. Why would it work in Beta but not Dev? Is there a toggle somewhere?

Enabled Enterprise State Roaming, which I thought was already enabled, and now Dev seems to be working.
I enabled enterprise state roaming and sync still isn’t working. Error on windows is “syncing is not available right now. Check your settings and try again” then under the profile, sync is greyed out and it says “to resume sync, sign out and then sign in again” which does nothing.

On my Mac it says “Sync is not yet available for work or school accounts”

I have the latest beta version and have AzureAD P1

@Michael Rennie We haven't yet rolled out AAD sync for macOS. That is coming soon so error you see on macOS is expected. We expect sync to work fine on Windows if you have ESR enabled. Can you submit in-app feedback and PM me your email address? 


We are working to update the sync articles we published a while ago ( with the latest status to offer all our customers visibility into the current state in addition to improving error messaging in app.


Thank you for your patience and help in making Edge a better browser. 

// @stevenmbriggs 


I'm a little shocked this doesn't work out of the box with a standard Office 365 account.


There's no way I can justify cranking up the AD Premium just for syncing services in Edge. Our users love it, and have been crying out for account sync.


I've a feeling lots of them will move back to Chrome after learning they're not getting sync on their accounts.

@b33rdy I did figure out that the sync wasn't working with the Dev Preview.  The BETA let me sign in but syncing seemed a bit wonky.  I installed BETA on a laptop and it immediately grabbed my Chrome bookmarks and settings before I could sync.  When I tried to sync with my Microsoft account, nothing really happened.  I'm going to try with a brand new laptop without any previous Chrome installations.

@akhator, any update on when sync for AAD accounts on macOS is coming?

Hey @akhator!


I understand that you posted that you're exploring other ways for other AAD SKUs to be able to sync. I'm interested to know if this has got any further yet?


Google Chrome enables this feature for all customers and Microsoft enables it for home accounts, so why not people who actually pay you money, no matter what SKU they have?


First line workers who just have an exchange account (Office 365 E1) for example, would love this feature to be able to save passwords and have consistent experiences between computers.


It would be great to see this moving forward if at all possible.


Thanks in advance


@dorgold Sync for AAD accounts is already enabled for MacOS. Thanks for your patience.

@akhator Is there special setup required for syncing an enterpise account? My company has a AAD P1 subscription. On my desktop client (81.0.389.2 Dev) using my work account I get a error that "Sync isn't available right now" and "Couldn't connect to the server. Retrying...". I have a personal profile setup and that seems to be working without issue. Any suggestions?


Having the same issue here. Looking at  Version 79.0.309.71 (Official build) (64-bit), our work accounts will not sync with error: Sync isn't available right now. & Hmmmm....we're having trouble verifying your account details.


Yet, Sync for our work accounts was working fine in the older Edge. We have AAD Prem and Enterprise Roaming is enabled and has been for a long time. Our Windows 10 Enterprise settings sync and work fine with our work accounts. Just not the new Edge.

Digging a bit more (edge://sync-internals/), I see this: EDGE_AUTH_ERROR: 3, 13, caa2000c


Looking around it may seem like it has to do with MFA. We do require all users to use MFA, however this does not have any issues with Windows 10 Syncing since we do get MFA prompts for almost anything we log into through Windows. However, I do not get a MFA prompt when I log into the New Edge browser.

@Kirby Stuart I see that same error too. However, we have MFA enabled and it works for other users in our ORG. When they sign into Edge from outside out trusted network they get prompted as normal and after approving, sync works fine.


So far only my account continues to get the sync errors.

@Kirby Stuart I do have MFA setup on my account, however our conditional access policy is configured such that when connecting from a trusted IP MFA isn't required.