MS Edge Beta can't play Netflix on Ubuntu

Established Member

I am not able to play any Netflix videos on MS Edge Beta in Ubuntu. But I can play the same on other browsers - Chrome and Firefox on the same machine. This is the error I am getting on Edge.



Screenshot from 2021-05-09 18-25-29.png


I have tried with both HW acceleration on and off, but nothing works. I am getting the same error message. Below is my system spec - 


OS - Ubuntu 20.04.2 LTS

MS Edge Beta - Version 91.0.864.19 (Official build) beta (64-bit)


As widevine is available for MS Edge in Linux, I thought I could play Netflix on Edge. Please help.

4 Replies

Same issue here. Same Edge version with Manjaro Linux. It seems to be a user-agent problem where Netflix doesn't recognice edge's one. 


I change the user-agent with "User-agent switcher" extension in Edge and problem solved.

I install "User-agent switcher" extension in Edge Beta.
Choose opera Browser and Microsoft windows.
It could work on my Ubuntu 20.04.2 LTS and problem solved.

Yes, the same here.
Installed the user-agent switcher and I pretend to be a Chrome for Linux. Netflix streamming works now.


This solution solved the exact same problem for me too. Thank you!