Missing history button in Edge Stable?

Brass Contributor

I've waited a while to ask this because I thought maybe it's a feature that's being rolled out in stages but it seems to have been around for a long time now and rolled out simultaneously on all of my other devices but I can't see the new history button in Edge Stable on my desktop PC. I also don't have any option to turn it on even:

I've tried resetting Edge by deleting the entire profile folder and setting up from scratch but that also didn't help. I do have the Vertical Tabs, etc. already.

My Edge details are (Windows 10 Pro x64):


70 Replies


Version 90 and still don't have this despite seeing it on all the other devices I have and work with.

I tried HotCakeX's shortcut target on this new version 90 and it didn't help either.

Can anyone on the Edge team give advice on what is going on or when this feature rollout is expected to complete?

Hi In another post was an explanation unambiguous that such implementation is staged and it is not possible that at the same time all computers in the world I immediately had! please wait! Thank you
I also find it odd that I have a desktop PC which has the latest updated version of Edge. This displays the history button correctly in one user account but not another. I am talking about Windows user accounts not Edge profiles. If I generate a new account the the history button is present as expected. But the original account never gets the button. I believe it is a glitch in the settings as all other accounts on PC work fine.
Hi You found a solution to your problem, in my opinion set the settings as default Edge browsers, in this account - a profile on which you do not see the history button! Or remove this profile from your browser and sync your Microsoft account again – write which method was best luck.
That’s where it gets strange. I have reset browser settings on the account that doesn’t show the button. I have also completely deleted the browser profile and rebuilt it neither works. The only way I can get the button is on a fresh Windows User account.
And removing the Microsoft account from Windows and re-syncing if it was already ?- Thank you!
I cannot remove the account as it will remove Alll my user data and may impact on registration of software such as Office 365.
Remove synchronisation from windows on a given computer-after re-adding the Microsoft account restores all the data as if you added a new computer to your Microsoft services, it is safe but there is always some risk, but there is certainly no reason to do it again, only to see if the history button will return, as you have on another profile Ok I would leave it and not looking for = another Windows update already close
@josh_bodner, Today my PC updated to Version 90.0.818.62 (Official build) (64-bit) this has NOT resolved the issue where on the PC I have User account A on that PC that does not show the button still, and on Windows user accounts B and C which shows the button as expected with the new rollout.
I no longer believe this is 'an expected behavior' as that PC shows the new history functionality with all accounts except the one Windows User Account. As mentioned before I have deleted the Edge profile associated with that user account and reset Edge, any other suggestions would be welcome.
BTW I would uninstall & reinstall Edge but there is no longer a way to do this (unless someone knows better)
Yep I too am running Version 90.0.818.62 (Official build) (64-bit) and also still have no sign of this History menu. It's really starting to seem like this is a bug at this point but since we don't have any information from the Edge team about the rollout of this feature it's difficult to know if it's a bizarrely slow feature rollout. I feel at this point I might only get this feature in a few years when I upgrade my computer because it doesn't seem to like something about this one.
yep, I feel you are right @DanielRyan, I have a 6 month old laptop as well as my main PC, and running on the same A/C it gets all the latest Edge features when they are released !
I believe MS people are trying to pull the wool over us quoting A/B Rollout testing as an excuse for a broken feature. I'm sure a quick reg tweak should fix our problem, which may have arisen from the history of our machines... mine for example was an upgrade from Windows 8.
I just updated to the very latest stable release. STILL no History button available in the options. I fear it is a corrupt registry entry for the one Windows profile. I am happy to make changes at my own risk but I do not want to move my existing profile to a new one with the button. Can anyone steer me in the right area?
V 91.0.864.48

Yep I'm now on v. 91 as well and still no history button. I work with managing computers and basically I'm seeing it available on every computer I work with now but not my own personal one. I wonder if it's possibly due to having installed Edge from the very earliest download version that was available via the Google search before it was officially released.



I ask if by default you have Microsoft Bing?

I also installed earlier than all Edge and it works properly 

I had the button on windows 10. Then I updated to Windows 11 and now I don't have it anymore!!! 🤦‍:male_sign:
Actually that gives me some hope! Obviously Microsoft haven't rolled it out to everyone and maybe I'm just part of the group they are testing by making us wait longer. I do find the whole thing super confusing and unsatisfactory though because I'm often getting features (in my release install) that supposedly are still in beta but then I'm missing on the History button and the Downloads button both of which appear on all the other computers I support and work with.

It's so inconsistant, you never know what features will be available on a computer and they also don't consistantly follow the version numbering. It's almost like a psychological experiment Microsoft is carrying out on users to confuse them. It also makes supporting and helping people more difficult because you can't have any real idea what features Microsoft have randomly blessed them with. I understand release waves and test phases and how useful they are but they should match version numbers and users should be able to understand what features they have available. This is just frankly offputting.

So I got tired of waiting. I uninstalled Edge using the instructions here:
How to Permanently Remove Microsoft Edge From Windows 11 Using Powershell (
I restarted the computer. Then I reinstalled it from a file (v. 91.0.864.53) 
And it worked!! I got them!!!
I used it for a while perfectly happy. But then I went to [Options, Help, About Edge] and it began to update (v. 91.0.864.67). After that, it restarted and the buttons were gone again.... 

All part of their master plan to drive us mad and move to Mac OS!

@DanielRyan indeed. I installed the beta version and moved on. The buttons are there now