Missing flag in Dev channel: #global-media-controls [Solved]

Copper Contributor



That flag was just there yesterday.


I'm using both Edge Legacy and Edge Dev.


In the morning, I updated my built-in Edge Legacy to Edge Chromium. Didn't like it over Edge Legacy. Uninstalled after a short time, returned to Legacy. While doing that, I also deleted a bunch of unused registry keys and leftovers with CCleaner after uninstalled Chromium update.


Later, I opened Edge Dev for usual browsing intentions but didn't see global media controls option on toolbar while playing some media. Checked the flag right away and there was no sign of a flag.


How could that be happened? Did I mistakenly delete some app settings on Windows? But I reinstalled the app [Edge Dev] though. Shouldn't that be enough to restore missing necessities? Any ideas on what should I do?


p.s. I uninstalled Edge Dev and cleared leftovers, reset Edge Legacy's data, reinstalled Edge Dev and the problem is still persisting. Also tried with Edge Canary and with different outlook account, still no hope. Help :(


Annotation 2020-06-04 154236.jpg


3 Replies
i have the same problem



Just apply @eddiezato's solution from here:


I didn't know how to apply command-line switch, If you're like me, just open properties of Edge Dev shortcut and add the aforementioned code at the end of "Target:"


It should look like this: "C:\Program Files (x86)\Microsoft\Edge Dev\Application\msedge.exe" --enable-features=GlobalMediaControls



best response confirmed by jenkisKhan (Copper Contributor)



Flag is back in Canary "Version 85.0.541.0 (Official build) canary (64-bit)" as of today.


Annotation 2020-06-08 152317.jpg