Microsoft Launcher not quite working with Android 11

%3CLINGO-SUB%20id%3D%22lingo-sub-1646420%22%20slang%3D%22en-US%22%3EMicrosoft%20Launcher%20not%20quite%20working%20with%20Android%2011%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1646420%22%20slang%3D%22en-US%22%3E%3CP%3EI%20would%20have%20assumed%20that%20the%20ms%20launcher%20was%20getting%20tested%20with%20the%20developer%20previews%20of%20android%2011.%20However%2C%20it%20does%20not%20appear%20to%20be%20the%20case.%20Android%2011%20was%20officially%20released%20today%2C%20and%20of%20course%2C%20I%20updated%20it.%20Microsoft%20Launcher%20would%20start%20up%2C%20but%20after%20loading%20any%20app%20and%20going%20back%20to%20the%20home%20screen%2C%20the%20Microsoft%20Launcher%20would%20be%20gone%20like%20it%20crashed%20or%20something%2C%20and%20the%20phone%20goes%20back%20to%20the%20original%20launcher%2C%20the%20pixel%20launcher%20in%20my%20case.%20I%20can%20re-launch%20the%20microsoft%20launcher%2C%20but%20then%20again%2C%20open%20ANY%20other%20app%2C%20then%20go%20back%20home%20and%20it's%20back%20to%20the%20pixel%20launcher%20and%20not%20the%20MS%20launcher%20as%20it%20should.%20I%20have%20also%20checked%20that%20MS%20Launcher%20is%20still%20the%20%22default%20home%20app%22%20which%20it%20is.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1646607%22%20slang%3D%22en-US%22%3ERe%3A%20Microsoft%20Launcher%20not%20quite%20working%20with%20Android%2011%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1646607%22%20slang%3D%22en-US%22%3EWell%2C%20it%20seems%20an%20additional%20reboot%20of%20the%20phone%20on%20top%20of%20the%20android%2011%20update's%20forced%20reboot%20was%20necessary%20to%20get%20things%20back%20to%20normal.%20When%20in%20doubt%2C%20just%20reboot%20I%20guess.%20So%20far%20after%20a%20manual%20reboot%2C%20the%20MS%20launcher%20is%20persisting%20after%20starting%20up%20an%20app.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1650113%22%20slang%3D%22en-US%22%3ERe%3A%20Microsoft%20Launcher%20not%20quite%20working%20with%20Android%2011%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1650113%22%20slang%3D%22en-US%22%3E%3CP%3EI'm%20having%20the%20same%20issue.%20Just%20updated%20to%20Android%2011.%20Rebooted%20twice%20but%20issue%20is%20still%20there.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1654487%22%20slang%3D%22en-US%22%3ERe%3A%20Microsoft%20Launcher%20not%20quite%20working%20with%20Android%2011%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1654487%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F61076%22%20target%3D%22_blank%22%3E%40Will%20Y%3C%2FA%3E%26nbsp%3BThis%20is%20happening%20with%20me%20also.%20If%20it%20helps%20I%20am%20using%20a%20Pixel%204a%20and%20I%20have%203%20button%20navigation%20turned%20on%20and%20the%20problem%20happens%20anytime%20I%20use%20the%20app%20switch%20button%20and%20then%20the%20back%20button.%20Pressing%20the%20home%20button%20brings%20the%20launcher%20back%20up.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1654600%22%20slang%3D%22en-US%22%3ERe%3A%20Microsoft%20Launcher%20not%20quite%20working%20with%20Android%2011%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1654600%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F789305%22%20target%3D%22_blank%22%3E%40Togurt%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EPixel%203XL%20and%20gesture%20navigation.%20it%20has%20been%20fine%20after%20I%20manually%20rebooted%20the%20device.%20sounds%20like%20there%20may%20still%20be%20an%20issue%20given%20your%20and%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F418709%22%20target%3D%22_blank%22%3E%40David1360%3C%2FA%3E's%20reply.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Contributor

I would have assumed that the ms launcher was getting tested with the developer previews of android 11. However, it does not appear to be the case. Android 11 was officially released today, and of course, I updated it. Microsoft Launcher would start up, but after loading any app and going back to the home screen, the Microsoft Launcher would be gone like it crashed or something, and the phone goes back to the original launcher, the pixel launcher in my case. I can re-launch the microsoft launcher, but then again, open ANY other app, then go back home and it's back to the pixel launcher and not the MS launcher as it should. I have also checked that MS Launcher is still the "default home app" which it is.

9 Replies
Well, it seems an additional reboot of the phone on top of the android 11 update's forced reboot was necessary to get things back to normal. When in doubt, just reboot I guess. So far after a manual reboot, the MS launcher is persisting after starting up an app.

I'm having the same issue. Just updated to Android 11. Rebooted twice but issue is still there.

@Will Y This is happening with me also. If it helps I am using a Pixel 4a and I have 3 button navigation turned on and the problem happens anytime I use the app switch button and then the back button. Pressing the home button brings the launcher back up.

@Togurt 

Pixel 3XL and gesture navigation. it has been fine after I manually rebooted the device. sounds like there may still be an issue given your and @David1360's reply.

I am having the same issue on a Samsung galaxy Note 20 Ultra, albeit the issue existed already in Android 10, it seems it is more related to gesture navigation, it's also working sometimes, which is odd
Thanks for your feedback. However it's a OS system issue. We wish we could make some fix, but we are afraid there is nothing we could do now. We suggest you give your feedback to Samsung forum(link). Please refer to more detail in our FAQ https://arrowlauncher.uservoice.com/admin/faqs/1961440/?q=status%3Apublished Thanks for your understanding.
This is also happening to my OnePlus 8 5G UW. I have my phone set to reboot every night. That doesn't work. I guess we'll have to wait for for the developers to figure out how fix this glitch.
I may have a fix, not sure how permanent. But I closed out my apps and it stayed. Go into the app settings for Microsoft launcher, set it as default, it has an option for "show on top" I turned it on, another for "allow app to make changes" I turned it on as well. Like I said, I dont know if it is permanent, but it did work. Also, the default home screen was not set to Ms launcher.