Microsoft Edge - PDF Edits Won't Save

Copper Contributor

I've been editing these PDFs using Microsoft Edge for a while now, but recently came across an issue. Whenever I go to save the edited PDF to a new folder, the preview and the saved PDF show the original information.


I've tried saving the document using the save button, the save as button, and the print button (save as PDF). No matter which option I use, it will not save the new information.


I've tried refreshing the page (which gets rid of all my edits), closing and reopening the PDF, closing and reopening Microsoft Edge, restarting my computer, and shutting down my computer completely. I've also tried checking for updates, clearing my browsing history, and resetting the settings.


Any advice is greatly appreciated as this is severely slowing down my progress.

4 Replies
What sort of edits are you making? Text annotations? Inking?

@josh_bodner I'm filling in information for a Bill of Lading. All I'm doing is changing dates, quantities, and so on. In the past, I've had no trouble replacing the old text with the new information.


At this point, I'm able to replace the text but it doesn't show when I save it or preview to print/save as PDF.

Ah, so the PDF has fillable form fields. I can't reproduce this issue with test PDFs, so I'm curious if you can also reproduce this with your specific PDF in an Insider version of Edge like Dev or Beta.

@RAmmerman Good day, Please have you sorted out the issue and how. I seem to be having the same problem with the new Edge update.