Microsoft Edge crashes on Linux with work profile

Copper Contributor

When I create a new profile with a work account which is Office 365 the application crashes while syncing. This happens only on Linux machines. The console output is the following:

 

 

 

[28677:28677:0125/121648.674068:ERROR:assistance_home_client.cc(32)] File path /home/ahumeniy/.config/microsoft-edge/Profile 2
[28677:28677:0125/121648.702712:ERROR:assistance_home_client.cc(32)] File path /home/ahumeniy/.config/microsoft-edge/Default
libva error: vaGetDriverNameByIndex() failed with unknown libva error, driver_name = (null)
[28677:28892:0125/121649.724319:ERROR:encryption_keys_manager_aad.cc(593)] Failed to decrypt new key.
[28677:28892:0125/121649.724521:ERROR:encryption_keys_manager_aad.cc(197)] Got invalid encryption keys!
[28677:28892:0125/121649.724609:ERROR:processor_entity.cc(171)] Metadata has an exisiting server id that will be overwritten with the current update entity id.metadata server_id: 1e9f9849-c6c8-5565-a9bf-ae726fd04f3c update.entity.id: 1e9f9849-c6c8-5565-a9bf-ae726fd04f3c
[28677:28677:0125/121650.163860:ERROR:object_proxy.cc(623)] Failed to call method: org.freedesktop.ScreenSaver.GetActive: object_path= /org/freedesktop/ScreenSaver: org.freedesktop.DBus.Error.NotSupported: This method is not implemented
[28723:28723:0125/121656.140500:ERROR:gl_surface_presentation_helper.cc(260)] GetVSyncParametersIfAvailable() failed for 1 times!
[28723:28723:0125/121702.153755:ERROR:gl_surface_presentation_helper.cc(260)] GetVSyncParametersIfAvailable() failed for 2 times!
[28723:28723:0125/121705.161887:ERROR:gl_surface_presentation_helper.cc(260)] GetVSyncParametersIfAvailable() failed for 3 times!
[0125/121805.284480:ERROR:elf_dynamic_array_reader.h(64)] tag not found
[0125/121805.285208:ERROR:elf_dynamic_array_reader.h(64)] tag not found
[0125/121805.286004:ERROR:elf_dynamic_array_reader.h(64)] tag not found
[0125/121805.286226:ERROR:elf_dynamic_array_reader.h(64)] tag not found
[0125/121805.286286:ERROR:elf_dynamic_array_reader.h(64)] tag not found
[0125/121806.220246:ERROR:directory_reader_posix.cc(42)] opendir /home/ahumeniy/.config/microsoft-edge/Crash Reports/attachments/cb70176a-b258-4782-84f2-c4b20a46f405: No such file or directory (2)
Segmentation fault (core dumped)

 

 

 Deleting ~/.cache/Microsoft directory kind of solves the problem but sync is disabled permanently having to log out and log in again to enable sync and it resumes crashing.

 

Changing the search provider as suggested in other topics didn't resolve the problem either.

19 Replies
I am seeing the same thing. I'm running Fedora 36 under Sway. However, on a different machine running Arch and i3 (with an Edge install that's a few weeks older), everything works fine.
Same issue here. Fedora 37 with Microsoft Edge 110.0.1587.41.

Same issue here on openSUSE Tumbleweed with Edge 110.0.1587.49

Hi @ahumeniy,

 

It seems resolved by updating to Microsoft Edge 110.0.1587.50.

Nope, still crashing

Same issue here. Fedora 37 and using my work profile.

 

I'm able to successfully use Edge by enabling Flatpak support in Fedora and using the unofficial Edge image from there, but the official RPM crashes trying to sync.

same here on Fedora 37
Same. Fedora 37.

@ahumeniy I have the same problem. Installing from Flatpak fixes it, but the AUR version seems to be broken.

 

@Carlos_Parada - same for me. broken for all versions on AUR (stable, beta and dev), but has not crashed yet using Flatpak.
Still happening on openSUSE Tumbleweed (RPM, official repository) on all channels (edge-stable, edge-beta, edge-dev).

This issue is not present on KDE Neon distribution

Flatpack does not have this problem (but many others)
Any solutions for this? On my Tumbleweed Edge crashes only in YouTube full-screen, all builds, stable, Dev, even Flatpak. I'm too used to Edge and too old to change.
The problem still persists on RHEL9. Tested stable and dev version. Any new information on this issue?

Same here, with Gnome in Fedora 39

Same error, seems that the JSON from welcome on the work profile is not supported on the RPM:
[35887:35887:0112/152637.955369:ERROR:CONSOLE(1)] "Uncaught (in promise) SyntaxError: Unexpected end of JSON input", source: edge://welcome/ (1)
[0112/152638.060327:ERROR:elf_dynamic_array_reader.h(64)] tag not found
[0112/152638.061988:ERROR:elf_dynamic_array_reader.h(64)] tag not found
[0112/152638.063810:ERROR:elf_dynamic_array_reader.h(64)] tag not found
[0112/152638.064205:ERROR:elf_dynamic_array_reader.h(64)] tag not found
[0112/152638.064838:ERROR:elf_dynamic_array_reader.h(64)] tag not found
[0112/152638.065172:ERROR:elf_dynamic_array_reader.h(64)] tag not found
[0112/152638.065463:ERROR:elf_dynamic_array_reader.h(64)] tag not found

@natanaelgonzalesSame and same on Rocky / RHEL 9

I have the same problem when I'm using Debian 12 with the latest GNOME version. I used Microsoft Edge for Linux in Ubuntu before a few months. Edge still working at that time.

@ahumeniy I have the same problem, Linux Mint 21.3, Microsoft Edge 124.0.2478.80 (Official build) (64-bit)


Please, someone do something

@rtollert ,

I am having problems on ubuntu, but none on Fedora 39.  I may try to upgrade to latest ubuntu.