Mac Edge Bug Report: Won't Launch when Another User on Mac Hasn't Done Final Install Step

Copper Contributor

Hi Edge Team,


Former Microsoft employee here. First, TERRIFIC product. Great job taking the Chromium engine, adding performance, etc. Thank you for finally bringing sanity to MSFT's browser strategy. 


BUG: On Mac OSX 11.4 (Big Sur) at least, if another user hasn't done the "first time launch", yet has logged in to the Mac, has say Google Chrome loaded and is dormant, when you switch over to the other user account and try to launch Edge, it freezes and doesn't load at all. You can type things into the URL bar, but it doesn't attempt to load the page. 


How I noticed this: We have a shared kitchen computer where my wife, kids and I each have different logins. I noticed that frequently when I logged in to my account on this shared machine, launched Edge on it, that it was nonresponsive. I'd force quit Edge, relaunch it (staying within my account), and nothing. Still non-responsive.

But I noticed something. EVERY SINGLE TIME when this happened, my wife's login (she doesn't use Edge at all yet, she uses Safari and sometimes Google Chrome) had the "my account has been backgrounded" icon. 

I finally switched over to her account, and tried to launch Edge. It worked, but I noticed that after over a year since first install on MY (admin powered) account, up came the "Welcome to Edge" for my wife's version. After that was done, I went back over to my account, had to restart Edge, and it worked just fine. 



0 Replies