Losing ability to set permission for individual cookies

Occasional Contributor

Dear all,


For the last 2 dev release, I've lost the ability to set the cookies individually to allow/delete when closed.


OS: Windows 10 20H2 Build 19042.630

Edge: Dev 88.0.702.0 64-bit


My Edge is set to reject all cookies (whitelisting only). In older release (example is Edge version 86.0.622.69):

1. Open a webpage that loads cookies

2. On the URL bar, there is a cookie icon with red X (indicating that there are cookies that are blocked)

3. Click on it, the cookies setting pop up. On the blocked tab, select the cookie to allow/permit to load until closed.

4. Click allow to allow the cookies permanently (whitelisted) or click remove when finished (have the cookies available until Edge is closed).

5. A text confirms that the cookie is set to allow or set to remove when finished.

6. Click finish.

7. The notification bar will pop up asking to refresh (since you change the webpage settings).

8. The URL of where the cookie comes from was then set into the list (Website Permissions > Cookies > Allowed Cookies / Remove When Finished).


Current Dev release no longer does that. Step 4-8 is no longer functional. The button, when clicked did nothing to each individual cookies, and the only way to whitelist cookies is to whitelist ALL cookies loaded for that page (which is not desired or wanted at all). I've uploaded a short video to explain what I meant.


Can anyone try this in their release and see if it behaves the same? My suspicion was the code was broken when the dev team updates the code for the popup to show a message asking if the page is working or not (check attached screenshot - image.png). Thanks.

6 Replies

Nobody can help? Maybe @HotCakeX ?

best response confirmed by flyingplastic (Occasional Contributor)



Which method do you use for whitelisting cookies?

I did this (which might not be the correct way)


and then when I go to a site like, the "clear upon exit" button doesn't work. the URL is never added to edge://settings/content/cookies

which is a bug.

the "Allow" button sometimes works but most of the time doesn't. 


I'm going to send a feedback through Edge browser right now, you also please do the same, more feedback means more data and higher priority.

also in the feedback window => Attachments => Recreate my problem => Start recording


do the same thing you did in your video again and let Edge record that.


Yes! Exactly! You're lucky the allow button works sometimes, mine no longer works at all. Just tried the same in Edge 87 (the non-dev channel) and works perfectly. My whitelisting method is the same as yours, but instead of specifying http://* and https://* in blocked list, I've just turn off the 'allow sites to save and read cookie data' and turned on the 'block third-party cookies'.


My guess somebody broke the code when updating either the allow cookie popup, or the backend (the settings page for cookies and website settings have all changed from previous release).

Thank you, I've send the feedback too.

Yes I think you're right, thanks, our feedbacks will be useful for fixing this :)



this is fixed now and works like a charm in Edge Version 89.0.739.0 (Official build) canary (64-bit)

will make it to the Dev channel early next year :)


@HotCakeX Yes, just upddated mine and works wonderfully like it used before. Thank you for your help.


And thanks to @josh_bodner and the team for fixing this. :smile: