Linux process port binds

%3CLINGO-SUB%20id%3D%22lingo-sub-2205424%22%20slang%3D%22en-US%22%3ELinux%20process%20port%20binds%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2205424%22%20slang%3D%22en-US%22%3E%3CP%3EI've%20started%20using%20Microsoft%20Edge%20Dev%20on%20my%20Linux%20workstation%2C%20and%20I%20noticed%20that%20%3CSTRONG%3Emsedge%3C%2FSTRONG%3E%20binds%20to%20a%20multicast%20address%2C%20a%20UDP%20port%20and%20a%20UDP6%20port.%26nbsp%3B%20What%20are%20these%20listening%20sockets%20doing%2C%20and%20how%20do%20I%20disable%20them%3F%20I've%20looked%20through%20every%20configuration%20option%20I%20can%20find%20in%20the%20Settings%20section%20and%20nothing%20seems%20to%20be%20related%20to%20these%20socket%20binds.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CPRE%20class%3D%22lia-code-sample%20language-bash%22%3E%3CCODE%3EProto%20Recv-Q%20Send-Q%20Local%20Address%20%20%20%20%20%20%20%20%20%20%20Foreign%20Address%20%20%20%20%20%20%20%20%20State%20%20%20%20%20%20%20PID%2FProgram%20name%0Atcp%20%20%20%20%20%20%20%200%20%20%20%20%20%200%200.0.0.0%3A22%20%20%20%20%20%20%20%20%20%20%20%20%20%200.0.0.0%3A*%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20LISTEN%20%20%20%20%20%20-%0Atcp6%20%20%20%20%20%20%200%20%20%20%20%20%200%20%3A%3A%3A22%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%3A%3A%3A*%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20LISTEN%20%20%20%20%20%20-%0Atcp6%20%20%20%20%20%20%200%20%20%20%20%20%200%20%3A%3A%3A9100%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%3A%3A%3A*%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20LISTEN%20%20%20%20%20%20-%0Audp%20%20%20%20%20%20%20%200%20%20%20%20%20%200%200.0.0.0%3A68%20%20%20%20%20%20%20%20%20%20%20%20%20%200.0.0.0%3A*%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20-%0Audp%20%20%20%20%20%20%20%200%20%20%20%20%20%200%20224.0.0.251%3A5353%20%20%20%20%20%20%20%200.0.0.0%3A*%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%2047505%2Fmsedge%20--type%0Audp%20%20%20%20%20%20%20%200%20%20%20%20%20%200%20224.0.0.251%3A5353%20%20%20%20%20%20%20%200.0.0.0%3A*%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%2047464%2Fmicrosoft-edg%0Audp%20%20%20%20%20%20%20%200%20%20%20%20%20%200%200.0.0.0%3A47167%20%20%20%20%20%20%20%20%20%20%200.0.0.0%3A*%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%2047505%2Fmsedge%20--type%0Audp6%20%20%20%20%20%20%200%20%20%20%20%20%200%20%3A%3A%3A43504%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%3A%3A%3A*%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%2047505%2Fmsedge%20--type%0Araw%20%20%20214272%20%20%20%20%20%200%200.0.0.0%3A17%20%20%20%20%20%20%20%20%20%20%20%20%20%200.0.0.0%3A*%20%20%20%20%20%20%20%20%20%20%20%20%20%20%207%20%20%20%20%20%20%20%20%20%20%20-%0Araw6%20%20%20%20%20%20%200%20%20%20%20%20%200%20%3A%3A%3A58%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%3A%3A%3A*%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%20%207%20%20%20%20%20%20%20%20%20%20%20-%3C%2FCODE%3E%3C%2FPRE%3E%3C%2FLINGO-BODY%3E
New Contributor

I've started using Microsoft Edge Dev on my Linux workstation, and I noticed that msedge binds to a multicast address, a UDP port and a UDP6 port.  What are these listening sockets doing, and how do I disable them? I've looked through every configuration option I can find in the Settings section and nothing seems to be related to these socket binds.

 

Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      -
tcp6       0      0 :::22                   :::*                    LISTEN      -
tcp6       0      0 :::9100                 :::*                    LISTEN      -
udp        0      0 0.0.0.0:68              0.0.0.0:*                           -
udp        0      0 224.0.0.251:5353        0.0.0.0:*                           47505/msedge --type
udp        0      0 224.0.0.251:5353        0.0.0.0:*                           47464/microsoft-edg
udp        0      0 0.0.0.0:47167           0.0.0.0:*                           47505/msedge --type
udp6       0      0 :::43504                :::*                                47505/msedge --type
raw   214272      0 0.0.0.0:17              0.0.0.0:*               7           -
raw6       0      0 :::58                   :::*                    7           -
1 Reply
It looks like the two of the binds were from eBay. The :5353 binds were mDNS, and seem to be controlled by edge://flags/#enable-webrtc-hide-local-ips-with-mdns . Disabling that stops the multicast listeners. Though given what it actually does, it's not very offensive to have enabled.