Latest Edge Build Breaks Logmein

New Contributor

I am impressed with the Chromium-Edge Browser and have been using it as my default for a few months.  This evening, after coming home from work, I was presented with a new build and then went about my business.  

I needed to update a few systems at work and logged on to Logmein which had worked fine yesterday.  Now, when I select a computer to remote into, Edge displays an error page asking me to check firewall and proxy settings. It's a complete show stopper.

I tested with the original non-Chromium Edge and Logmein works fine.  I also reset the latest Chromium-build but still encountered the same issue.

I am interested in hearing if others are experiencing the same thing?

29 Replies
Which OS and Edge insider channel/version are you using?



Developers Channel

Microsoft Edge is up to date.Version 80.0.345.0 (Official build) dev (64-bit)


Any ideas?

Well it could be the new update breaking it or an extension was rendered incompatible or problematic after the update, could you please attach a screenshot of the error?



I had this issue for a while.

Same error. 

Here is the screenshot (in french unfortunatly).

So we are seeing the same here as well. 


Version 80.0.345.0 (Official build) dev (64-bit)

Windows 10 Ent 1903 (18362.418)


I get the same error, even if I access the portal using guest profile & no extensions enabled.




Same here, after update no longer can use Logmein to remote into a computer.

Version 80.0.345.0 was working on earlier builds.


I am having the exact same issue and now I cannot load Like you, I can login to LMI fine, but when I click on a computer, I get "Hmmm… can't reach this page The connection was reset.". Both sites work normally in all other browsers on my computers. I even went as far as installing the latest Edge Dev on a Windows Sandbox VM and both sites do not load. So that proves it is not something with my MS account sync. I also loaded Edge beta on the Sandbox VM and both sites work as they should.

I fully understand that this is pre-beta software and stuff like this happens, it is just weird that it started so close to the final release. I hope we get a new build soon. I hate having to use Chrome to do anything anymore. I have been using Edge Dev for a couple months now am ready to remove Chrome from my computer as soon as it is fully released.

Just updated to Version 80.0.355.1 (Official build) dev (64-bit) and LMI still doesn't work, neither does WTF?

@William-ACCI I too have noticed this exact issue with LogMeIn. Internet Explorer works fine. Just started around the 9th of December. Worked perfectly prior.


Windows 10 Enterprise 1909 18363.535

Edge: Version 80.0.361.5 (Official build) dev (64-bit)

LogMeIn client ver 1.3.4650


Would love to know when this is fixed!

Just updated to today's realease and LMI still does not work. Neither does in Edge Dev.

Hey, everyone! Thanks for bringing this to our attention. It seems this is happening in Chrome Canary as well (I tested myself with, I can't test with LogMeIn, though).


Know that we're aware of it and we'll circle back once we have more information. Appreciate the understanding!


Missy Quarry (she/her/hers)
Community Manager - Microsoft Edge



Will there be an update to Chrome Dev tomorrow (or next week) that will address these issues?

@MattGrant Since it's happening across chromium programs, I'm keeping an eye on when it's fixed there. I don't know Chrome's update schedule for their browsers explicitly, but our update for the Dev channel won't happen until next week due to the holidays.


Edited to add: To be clear, I don't know if a fix will be in place for this, but I will update you all once I know more information.


Missy Quarry (she/her/hers)
Community Manager - Microsoft Edge



Seems very weird to be happening in the fist place. Of all websites not working in Chromium, Micro Center is a very popular computer store/website (let alone LMI not working). Any guess as to what the issue is? Possibly browser identification to the server's hosting the sites?

@MattGrant This is the chromium bug listed for it. There's a lot of jargon I'm not 100% familiar with, but hopefully it helps you out.


Missy Quarry (she/her/hers)
Community Manager - Microsoft Edge



Thanks! I have been looking for the bug report for his issue.

@MattGrant Of course! It took me a while to find it myself last week, but I'm happy I did.


Again, I'll follow up once I have more information to share. Happy new year if we don't speak before then! :D


Missy Quarry (she/her/hers)
Community Manager - Microsoft Edge

@William-ACCI Can you please share the URL of the page that isn't working?

@MattGrant - The Microcenter problem is a bug in their website; we've reached out to them. The problem is also seen in the latest builds of Chrome (we're both based on Chromium). To workaround it, you can launch Edge like so:



   msedge.exe --disable-features=PostQuantumCECPQ2