Kinda weird behavior when launching Application Guard Window from inside inPrivate mode

%3CLINGO-SUB%20id%3D%22lingo-sub-839725%22%20slang%3D%22en-US%22%3EKinda%20weird%20behavior%20when%20launching%20Application%20Guard%20Window%20from%20inside%20inPrivate%20mode%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-839725%22%20slang%3D%22en-US%22%3E%3CP%3EWhen%20i%20first%20open%20an%20inPrivate%20windows%20and%20from%20there%20open%20an%20application%20guard%20window%2C%20it%20appears%20like%20this%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-center%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F130366i68BA1E9C42A6218F%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%221.png%22%20title%3D%221.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-center%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F130367iCABFD36CEBE73E7A%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%222.png%22%20title%3D%222.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESo%20it's%20Application%20guard%20mode%20but%20with%20the%20theme%20and%20feel%20of%20inPrivate%20mode.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ehere%20is%20how%20application%20guard%20window%20looks%20like%20when%20launched%20from%20normal%20browsing%20window%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-center%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F130369i2418018407B966B6%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22Annotation%202019-09-06%20005604.png%22%20title%3D%22Annotation%202019-09-06%20005604.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E1.%20so%20when%20application%20guard%20mode%20is%20launched%20from%20inside%20inPrivate%20mode%2C%20it's%20correctly%20taking%20the%20dark%20theme%20but%20not%20when%20launched%20from%20normal%20browsing%20window.%3C%2FP%3E%3CP%3E2.%20the%20application%20guard%20window%20is%20showing%20%22inPrivate%22%20icon%20on%20the%20tool%20bar%20(2nd%20picture)%20by%20mistake.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EVersion%2078.0.268.0%20(Official%20build)%20canary%20(64-bit)%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-839772%22%20slang%3D%22en-US%22%3ERe%3A%20Kinda%20weird%20behavior%20when%20launching%20Application%20Guard%20Window%20from%20inside%20inPrivate%20mode%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-839772%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310193%22%20target%3D%22_blank%22%3E%40HotCakeX%3C%2FA%3E%26nbsp%3BThanks%20for%20trying%20out%20the%20Application%20Guard%20integration%20work!%20The%20bug%20related%20to%20the%20black%20border%20around%20some%20of%20the%20dialogs%20in%20your%20screenshot%20should%20be%20resolved%20in%20the%20upcoming%20Windows%20Insider%20Fast%20build.%20As%20for%20the%20InPrivate%20mode%20feedback%2C%20Application%20Guard%20mode%20supports%20both%20Normal%20%26amp%3B%20InPrivate%20browsing%20inside%20the%20Application%20Guard%20Container.%20So%20if%20you%20use%20Normal%20browsing%20%26amp%3B%20launch%20Application%20Guard%20then%20it%20launches%20Normal%20Browsing%20mode%20inside%20the%20container%20and%20if%20you%20use%20InPrivate%20browsing%26nbsp%3B%20%26amp%3B%20launch%20Application%20Guard%20then%20it%20launches%20InPrivate%20Browsing%20mode%20inside%20the%20container.%20Please%20let%20me%20know%20if%20I%20misunderstood%20your%20question%20%26amp%3B%20Please%20keep%20the%20feedback%20coming!!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-839797%22%20slang%3D%22en-US%22%3ERe%3A%20Kinda%20weird%20behavior%20when%20launching%20Application%20Guard%20Window%20from%20inside%20inPrivate%20mode%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-839797%22%20slang%3D%22en-US%22%3EHi%2C%3CBR%20%2F%3Efair%20enough.%20yeah%20i'm%20still%20waiting%20for%20that%20Windows%20insider%20update.%3CBR%20%2F%3Ebut%20anyway%20there%20is%20still%20a%20problem%20though%20cause%20application%20guard%20launched%20from%20normal%20browsing%20doesn't%20have%20the%20dark%20theme%2C%20it's%20always%20white.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-842575%22%20slang%3D%22en-US%22%3ERe%3A%20Kinda%20weird%20behavior%20when%20launching%20Application%20Guard%20Window%20from%20inside%20inPrivate%20mode%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-842575%22%20slang%3D%22en-US%22%3EThe%20black%20bars%20around%20the%20UI%20of%20the%20application%20guard%20mode%20are%20gone%20now%20in%20insider%20build%2018975.%3C%2FLINGO-BODY%3E
Highlighted
Honored Contributor

When i first open an inPrivate windows and from there open an application guard window, it appears like this:

 

1.png

 

 

2.png

 

So it's Application guard mode but with the theme and feel of inPrivate mode.

 

here is how application guard window looks like when launched from normal browsing window:

 

Annotation 2019-09-06 005604.png

 

1. so when application guard mode is launched from inside inPrivate mode, it's correctly taking the dark theme but not when launched from normal browsing window.

2. the application guard window is showing "inPrivate" icon on the tool bar (2nd picture) by mistake.

 

Version 78.0.268.0 (Official build) canary (64-bit)

3 Replies
Highlighted

@HotCakeX Thanks for trying out the Application Guard integration work! The bug related to the black border around some of the dialogs in your screenshot should be resolved in the upcoming Windows Insider Fast build. As for the InPrivate mode feedback, Application Guard mode supports both Normal & InPrivate browsing inside the Application Guard Container. So if you use Normal browsing & launch Application Guard then it launches Normal Browsing mode inside the container and if you use InPrivate browsing  & launch Application Guard then it launches InPrivate Browsing mode inside the container. Please let me know if I misunderstood your question & Please keep the feedback coming!!

Highlighted
Hi,
fair enough. yeah i'm still waiting for that Windows insider update.
but anyway there is still a problem though cause application guard launched from normal browsing doesn't have the dark theme, it's always white.
Highlighted
The black bars around the UI of the application guard mode are gone now in insider build 18975.