Issue with new windows opening and pop ups

Brass Contributor

I do development in Microsoft Dynamics every day using Microsoft Edge.


Yesterday Edge started blocking certain things in Dynamics from opening.  It gives the error that a pop up blocker blocked it, but....  I haven't changed anything, I dont have any pop up blockers installed and I dont have any other toolbars installed.  I did verify that the url is allowed in the built in pop up blocker in edge.


Screenshot 2021-01-21 120848.png


The weird thing is everything works fine in Chrome and chrome has the same exceptions as Edge.


Not sure if anything new was pushed out that would be causing this but I cant think of anything else.



7 Replies

@Mattw112 We're experiencing the same situation, very annoying. Haven't found a fix or workaround, other than using a different browser. :(

Hey there, I'm sorry to see you're running into this issue with Dynamics and Microsoft Edge! Can you confirm what version of Edge you're running?

@Alexandra-R Microsoft Edge Version 89.0.767.0 (Official build) dev (64-bit)

@Alexandra-R please fix - im using Version 89.0.767.0 (Official build) dev (64-bit), I use D365 all the time, even if you turn pop-up blocker off you still get the pop-up blocker message.

Thanks for confirming the version! There are a few things to try to narrow down the culprit.


First, please try disabling Tracking Prevention at edge://settings/privacy and let me know if the behavior changes at all.


Second, please change the UA String to Chrome. From Developer tools (Ctrl+Shift+I) navigate to the customize and control DevTools "..." menu > More tools > Network conditions > Uncheck User agent > Select 'Chrome - Windows' and let me know if you see any changes in behavior. 


Please let me know if you have any questions! 



@Alexandra-R - hey apologies to side swipe the treat I have tried both the suggestion 1 at a time and all together, no joy :( - just to be clear steps taken, turned off pop-ups, disabling Tracking Prevention, and change the UA String to Chrome.

@Bradley_King Microsoft has said this is an issue with the current version of Edge.  I think we just have to wait?