SOLVED
Home

Is 'search and site suggestion' working properly?

%3CLINGO-SUB%20id%3D%22lingo-sub-861157%22%20slang%3D%22en-US%22%3EIs%20'search%20and%20site%20suggestion'%20working%20properly%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-861157%22%20slang%3D%22en-US%22%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F132344i35E6719AD3CE329C%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22Untitled-1.fw.png%22%20title%3D%22Untitled-1.fw.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3EI'm%20not%20sure%2C%20but%20I%20think%20this%20feature%20is%20not%20working%20the%20way%20it%20should.%20For%20example%2C%20if%20I%20start%20typing%20in%20the%20address%20bar%20the%20following%20text%20%22Best%20movies%20of%22%2C%20I%20imagine%20that%20this%20function%20should%20suggest%20sites%20to%20search%20or%20maybe%20auto-complete%20the%20sentence%2C%20but%20nothing%20is%20suggested.%20In%20the%20version%20of%20edge-chromium%20I%20am%20using%20the%20address%20bar%20only%20suggests%20pages%20I%20have%20already%20visited.%20(canary%20Version%2078.0.277.0)%3C%2FP%3E%3CP%3EIs%20this%20feature%20working%20correctly%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIn%20Edge-Chromium%3A%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F132352iE4D2B48F58DAF527%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22aaaaUntitled-1.fw.png%22%20title%3D%22aaaaUntitled-1.fw.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIn%20Google%20Chrome%3A%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F132351i66331DFF7F6A135C%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22Untitled-1.fw.png%22%20title%3D%22Untitled-1.fw.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-861454%22%20slang%3D%22en-US%22%3ERe%3A%20Is%20'search%20and%20site%20suggestion'%20working%20properly%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-861454%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F371597%22%20target%3D%22_blank%22%3E%40Wouldiwas_Shookspeared%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHi%20%3A)%3C%2Fimg%3E%3C%2FP%3E%3CP%3Ewhen%20I%20type%20in%20the%20same%20thing%20in%20my%20browser%20I%20get%20this%20result%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-center%22%20style%3D%22width%3A%20782px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F132383i14F4E97D7532E632%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22Annotation%202019-09-18%20205010.png%22%20title%3D%22Annotation%202019-09-18%20205010.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EVersion%2079.0.278.0%20(Official%20build)%20canary%20(64-bit)%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3Ethere%20are%20various%20flags%20related%20to%20the%20omnibox%20(the%20address%20bar)%20but%20I%20haven't%20activated%20any%20of%20them.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3Eyou%20can%20first%20update%20your%20Edge%20and%20then%20try%20again%2C%20hopefully%20it%20will%20work!%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-861473%22%20slang%3D%22en-US%22%3ERe%3A%20Is%20'search%20and%20site%20suggestion'%20working%20properly%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-861473%22%20slang%3D%22en-US%22%3E%3CP%3EHi%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F371597%22%20target%3D%22_blank%22%3E%40Wouldiwas_Shookspeared%3C%2FA%3E%2C%20Like%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310193%22%20target%3D%22_blank%22%3E%40HotCakeX%3C%2FA%3E%26nbsp%3BI%20am%20seeing%20the%20search%20suggestions%20pop%20up%20in%20the%20address%20bar%3A%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F132387iAE9C781161817DA8%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20alt%3D%22clipboard_image_0.png%22%20title%3D%22clipboard_image_0.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3EI%20would%20suggest%20looking%20to%20see%20if%20you%20have%20an%20update%20pending%20and%20then%20restart%20the%20browser.%26nbsp%3B%20If%20you%20are%20still%20seeing%20this%20issue%2C%20Please%20open%20a%20ticket%20with%20our%20support%20team%20(%3CA%20href%3D%22https%3A%2F%2Fmicrosoftedgesupport.microsoft.com%22%20target%3D%22_self%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fmicrosoftedgesupport.microsoft.com%3C%2FA%3E)%20so%20that%20we%20can%20help%20get%20you%20unblocked%20and%20understand%20if%20there%20is%20a%20bug%20in%20our%20search%20code.%26nbsp%3B%20Thanks%20-%20Elliot%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-861596%22%20slang%3D%22en-US%22%3ERe%3A%20Is%20'search%20and%20site%20suggestion'%20working%20properly%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-861596%22%20slang%3D%22en-US%22%3E%3CP%3EHi%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310193%22%20target%3D%22_blank%22%3E%40HotCakeX%3C%2FA%3E%26nbsp%3B%20and%26nbsp%3B%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F246288%22%20target%3D%22_blank%22%3E%40Elliot_Kirk%3C%2FA%3E%26nbsp%3B%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20found%20the%20cause%20of%20the%20problem%3A%20it%20was%20more%20or%20less%20my%20fault%2C%20but%20not%20entirely%2C%20lol%26nbsp%3B%3CIMG%20class%3D%22lia-deferred-image%20lia-image-emoji%22%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Fhtml%2Fimages%2Femoticons%2Ffacepalm_40x40.gif%22%20alt%3D%22%3Afacepalm%3A%22%20title%3D%22%3Afacepalm%3A%22%20%2F%3E%3CBR%20%2F%3EDo%20you%20still%20remember%20a%20bug%20that%20happened%20a%20few%20weeks%20ago%20when%20the%20Google%20search%20engine%20stopped%20working%20on%20Edge-Chromium%3F%20(Even%20with%20Google's%20search%20engine%20being%20selected%2C%20Bing's%20search%20engine%20was%20used.)%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWell%2C%20when%20that%20bug%20happened%20I%20got%20around%20the%20problem%20by%20manually%20adding%20a%20search%20engine%20to%20Google%20with%20the%20following%20URL%3A%3C%2FP%3E%3CP%3E%3CEM%3E%7Bgoogle%3AbaseURL%7Dsearch%3Fq%3D%25s%26amp%3B%7Bgoogle%3ARLZ%7D%7Bgoogle%3AacceptedSuggestion%7D%7Bgoogle%3AoriginalQueryForSuggestion%7D%7Bgoogle%3AassistedQueryStats%7D%7Bgoogle%3AsearchFieldtrialParameter%7D%7Bgoogle%3AsearchClient%7D%7Bgoogle%3AsourceId%7D%7Bgoogle%3AinstantExtendedEnabledParameter%7Die%3D%7BinputEncoding%7D%3C%2FEM%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20bug%20was%20fixed%2C%20but%20I%20forgot%20to%20check%20the%20search%20engines.%20I%20took%20a%20look%20now%20and%20I%20saw%20that%20besides%20that%20search%20engine%20that%20I%20had%20created%20for%20Google%2C%20now%20there%20was%20the%20%22default%22%20Google%20search%20engine%20with%20this%20URL%3A%3C%2FP%3E%3CP%3E%3CEM%3E%7Bgoogle%3AbaseURL%7Dsearch%3Fq%3D%25s%26amp%3B%7Bgoogle%3ARLZ%7D%7Bgoogle%3AoriginalQueryForSuggestion%7D%7Bgoogle%3AassistedQueryStats%7D%7Bgoogle%3AsearchFieldtrialParameter%7D%7Bgoogle%3AiOSSearchLanguage%7D%7Bgoogle%3AsearchClient%7D%7Bgoogle%3AsourceId%7D%7Bgoogle%3AcontextualSearchVersion%7Die%3D%7BinputEncoding%7D%3C%2FEM%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ENote%20that%20the%20URLs%20are%20not%20exactly%20the%20same.%20I%20just%20had%20to%20make%20this%20last%20URL%20the%20default%20search%20engine%20again%20and%20now%20everything%20is%20working%20as%20it%20should.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F132406iE5214E65F7D2E9F5%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22Untitlessssd-1.fw.png%22%20title%3D%22Untitlessssd-1.fw.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ENow%20it's%20working%20in%20Edge-Chromium%3A%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20963px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F132393iED0B57045CDD7535%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22Untitled-1.fw.png%22%20title%3D%22Untitled-1.fw.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-861640%22%20slang%3D%22en-US%22%3ERe%3A%20Is%20'search%20and%20site%20suggestion'%20working%20properly%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-861640%22%20slang%3D%22en-US%22%3E%3CP%3EThat's%20good!%20%3Athumbs_up%3A%3CBR%20%2F%3E%3CBR%20%2F%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-967063%22%20slang%3D%22en-US%22%3ERe%3A%20Is%20'search%20and%20site%20suggestion'%20working%20properly%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-967063%22%20slang%3D%22en-US%22%3E%3CP%3EHey%2C%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20used%20your%20fixed%20URL%20but%20I%20still%20don't%20get%20any%20suggestions%20when%20I%20search%20%3A(%3C%2Fimg%3E%20Any%20other%20ways%20to%20try%20and%20fix%20this%3F%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-967711%22%20slang%3D%22en-US%22%3ERe%3A%20Is%20'search%20and%20site%20suggestion'%20working%20properly%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-967711%22%20slang%3D%22en-US%22%3EWhich%20search%20engine%20%3F%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1121587%22%20slang%3D%22en-US%22%3ERe%3A%20Is%20'search%20and%20site%20suggestion'%20working%20properly%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1121587%22%20slang%3D%22en-US%22%3E%3CP%3EFor%20me%20it's%20google%20specifically%2C%20that's%20not%20working%20with%20suggestions%2C%20even%20if%20I%20paste%20%3CA%20href%3D%22https%3A%2F%2Fgoogle.com%2Fsearch%3Fq%3D%25s%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fgoogle.com%2Fsearch%3Fq%3D%25s%3C%2FA%3E.%20I%20am%20running%26nbsp%3B%3CSPAN%3E79.0.309.68%20(Official%20build).%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3EIn%26nbsp%3B80.0.361.33%20(Official%20build)%20beta%20it's%20working%20fine%2C%20though.%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1040734%22%20slang%3D%22en-US%22%3ERe%3A%20Is%20'search%20and%20site%20suggestion'%20working%20properly%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1040734%22%20slang%3D%22en-US%22%3ESame%20here%2C%20no%20suggestion%20words%20no%20matter%20which%20search%20engine%20I%20use...%3CBR%20%2F%3EUsing%20%60Version%2079.0.309.30%20(Official%20build)%20Beta%20(64-bit)%60%20on%20MacOS%20Mojave%3CBR%20%2F%3E%3C%2FLINGO-BODY%3E
Highlighted
Deleted
Not applicable

Untitled-1.fw.png

I'm not sure, but I think this feature is not working the way it should. For example, if I start typing in the address bar the following text "Best movies of", I imagine that this function should suggest sites to search or maybe auto-complete the sentence, but nothing is suggested. In the version of edge-chromium I am using the address bar only suggests pages I have already visited. (canary Version 78.0.277.0)

Is this feature working correctly?

 

In Edge-Chromium:

aaaaUntitled-1.fw.png

 

In Google Chrome:Untitled-1.fw.png

9 Replies
Highlighted

@Deleted 

Hi :)

when I type in the same thing in my browser I get this result:

 

Annotation 2019-09-18 205010.png

 

Version 79.0.278.0 (Official build) canary (64-bit)

 

there are various flags related to the omnibox (the address bar) but I haven't activated any of them.

you can first update your Edge and then try again, hopefully it will work!

Highlighted

Hi @Deleted, Like @HotCakeX I am seeing the search suggestions pop up in the address bar:

clipboard_image_0.png

I would suggest looking to see if you have an update pending and then restart the browser.  If you are still seeing this issue, Please open a ticket with our support team (https://microsoftedgesupport.microsoft.com) so that we can help get you unblocked and understand if there is a bug in our search code.  Thanks - Elliot

Highlighted
Solution

Hi @HotCakeX  and  @Elliot_Kirk  

 

I found the cause of the problem: it was more or less my fault, but not entirely, lol :facepalm:
Do you still remember a bug that happened a few weeks ago when the Google search engine stopped working on Edge-Chromium? (Even with Google's search engine being selected, Bing's search engine was used.)

 

Well, when that bug happened I got around the problem by manually adding a search engine to Google with the following URL:

{google:baseURL}search?q=%s&{google:RLZ}{google:acceptedSuggestion}{google:originalQueryForSuggestion}{google:assistedQueryStats}{google:searchFieldtrialParameter}{google:searchClient}{google:sourceId}{google:instantExtendedEnabledParameter}ie={inputEncoding}

 

The bug was fixed, but I forgot to check the search engines. I took a look now and I saw that besides that search engine that I had created for Google, now there was the "default" Google search engine with this URL:

{google:baseURL}search?q=%s&{google:RLZ}{google:originalQueryForSuggestion}{google:assistedQueryStats}{google:searchFieldtrialParameter}{google:iOSSearchLanguage}{google:searchClient}{google:sourceId}{google:contextualSearchVersion}ie={inputEncoding}

 

Note that the URLs are not exactly the same. I just had to make this last URL the default search engine again and now everything is working as it should.

 

Untitlessssd-1.fw.png

 

Now it's working in Edge-Chromium:

Untitled-1.fw.png

 

 

Highlighted

That's good! :thumbs_up:

Highlighted

Hey, 

 

I used your fixed URL but I still don't get any suggestions when I search :( Any other ways to try and fix this??

Highlighted
Which search engine ?
Highlighted
Same here, no suggestion words no matter which search engine I use...
Using `Version 79.0.309.30 (Official build) Beta (64-bit)` on MacOS Mojave
Highlighted

For me it's google specifically, that's not working with suggestions, even if I paste https://google.com/search?q=%s. I am running 79.0.309.68 (Official build).

In 80.0.361.33 (Official build) beta it's working fine, though.

Highlighted

What helped me [partially] is Ryan Shillington from https://superuser.com/questions/280694/how-can-i-share-my-google-chrome-search-engine-entries . I had Edge Beta as well, so I extracted the search engines from "%localappdata%\Microsoft\Edge\User Data\Default\Web Data" and "%localappdata%\Microsoft\Edge Beta\User Data\Default\Web Data" and compared them. Difference was mainly with IDs. So I've imported the entries from Beta. Surprisingly there were no duplicate entries after that except for... Google. There were 2 entries now with one having keyword "g_", which I did not add myself. And with it search suggestions worked. I've extracted keywords again and my "imported" entry and this new one did not differ in terms of search URL, but they had a lot of difference in other parameters. In the end I simply removed the non-working entry and edited keyword for the working one and made it default.

Now, it's a bit unclear to me why "import" worked this way, but I know what MS can do to make this a bit more transparent:

1. Add button to reset (or rather restore) Search Engines, that are created after "pure" installation of the browser.

2. Allow synchronization of them for the profile, similar to favorites.