is it possible to disable the "Restore pages" message?

Copper Contributor

Edge boots with a restore pages message constantly, which doesn't go away unless you click on it.

 

There seem to be many options to disable it on chrome and chromium, but haven't found any that work for Edge Dev.

26 Replies

@Globespy No idea, really. I use about half a dozen on each of two laptops and haven't had time to test them one by one. But I'm guessing that the restore sessions popup is triggered by something not properly closing a session--so it seems likely that an extension could do that. 
The best fix remains: it should be an option in settings to disable that. Even when I do genuinely crash the browser or the PC, I don't have any need to restore tabs in that way. History works fine for that.

@NewbUser I have found that by going to settings, and then "Start, Home, and New Tabs", that I can delete pages from starting up. There are actually 3 options for Edge startup. The first option is Open new tab page, second option is Restore Pages, 3rd options is Open These Pages. I had a long list of pages that kept opening up on the 3rd option and so I delete most of them. I closed Edge, opened it back up, and this time only a few pages, the ones I left in the list on the 3rd option. I'm guessing pages get added if I do not close them out before exiting out of Edge. I also did not get the Restore Pages pop up.

Expierenced this issue after a window11 update. Tried all the usual fixes in the browser. Finally ran a few virus checks and hunter killers. All browsers (Edge, Chrome, FireFox) start right up and do not want to restore. @NewbUser 

this worked for me, thanks buddy
Thank you Vinod, this worked nicely :)