is it possible to disable the "Restore pages" message?

%3CLINGO-SUB%20id%3D%22lingo-sub-1983275%22%20slang%3D%22en-US%22%3Eis%20it%20possible%20to%20disable%20the%20%22Restore%20pages%22%20message%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1983275%22%20slang%3D%22en-US%22%3E%3CP%3EEdge%20boots%20with%20a%20restore%20pages%20message%20constantly%2C%20which%20doesn't%20go%20away%20unless%20you%20click%20on%20it.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThere%20seem%20to%20be%20many%20options%20to%20disable%20it%20on%20chrome%20and%20chromium%2C%20but%20haven't%20found%20any%20that%20work%20for%20Edge%20Dev.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1983292%22%20slang%3D%22en-US%22%3ERe%3A%20is%20it%20possible%20to%20disable%20the%20%22Restore%20pages%22%20message%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1983292%22%20slang%3D%22en-US%22%3EHi%2C%3CBR%20%2F%3Ethere%20is%20an%20explanation%20here%20about%20this%3A%3CBR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fdiscussions%2Fupdated-dev-channel-update-to-88-0-705-9-is-live%2Fm-p%2F1969725%2Fhighlight%2Ftrue%23M40246%22%20target%3D%22_blank%22%3Ehttps%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fdiscussions%2Fupdated-dev-channel-update-to-88-0-705-9-is-live%2Fm-p%2F1969725%2Fhighlight%2Ftrue%23M40246%3C%2FA%3E%3CBR%20%2F%3E%3CBR%20%2F%3Ethere%20is%20no%20option%20currently%20in%20Edge%20to%20disable%20it.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2217976%22%20slang%3D%22en-US%22%3ERe%3A%20is%20it%20possible%20to%20disable%20the%20%22Restore%20pages%22%20message%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2217976%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F1000293%22%20target%3D%22_blank%22%3E%40blackhillsken%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHi%2C%3C%2FP%3E%3CP%3EWelcome%20to%20the%20community%2C%3C%2FP%3E%3CP%3Eplease%20take%20a%20moment%20and%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Farticles%2Fmicrosoft-edge-insiders-community-guidelines%2Fm-p%2F2214637%22%20target%3D%22_self%22%3Ereview%20the%20guidelines%2C%3C%2FA%3E%3C%2FP%3E%3CP%3Eone%20of%20them%20is%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fdiscussions%2Fupdated-dev-channel-update-to-88-0-705-9-is-live%2Fm-p%2F2217124%2Fhighlight%2Ftrue%23M45334%22%20target%3D%22_self%22%3Enot%20cross-posting%2Fduplicate%20posting%2C%3C%2FA%3E%26nbsp%3Bthe%20other%20one%20is%20not%20bumping%20old%20threads.%3C%2FP%3E%3CP%3EThank%20you%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2270472%22%20slang%3D%22en-US%22%3ERe%3A%20is%20it%20possible%20to%20disable%20the%20%22Restore%20pages%22%20message%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2270472%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F858070%22%20target%3D%22_blank%22%3E%40Alexandra-R%3C%2FA%3E%26nbsp%3B-%20thanks%20for%20the%20suggestion%2C%20but%20unfortunately%20this%20does%20not%20work%20for%20me.%3CBR%20%2F%3EOn%20restart%2Fstartup%20this%20popup%20constantly%20nags%20until%20it%20is%20clicked%20on%20(closed).%3CBR%20%2F%3ERunning%20%3CSPAN%3EVersion%2089.0.774.76%20(Official%20build)%20(64-bit)%3CBR%20%2F%3E%3C%2FSPAN%3EHere's%20how%20my%20settings%20look%20for%20your%20information%3A%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22Globespy_0-1618329748457.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F272523i262E8A43A9BB7B05%2Fimage-size%2Fmedium%3Fv%3Dv2%26amp%3Bpx%3D400%22%20role%3D%22button%22%20title%3D%22Globespy_0-1618329748457.png%22%20alt%3D%22Globespy_0-1618329748457.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2708290%22%20slang%3D%22en-US%22%3ERe%3A%20is%20it%20possible%20to%20disable%20the%20%22Restore%20pages%22%20message%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2708290%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F1052449%22%20target%3D%22_blank%22%3E%40FiveThumbs%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20this%20problem%20also%2C%20on%20multiple%20devices.%20On%20all%20devices%3A%3C%2FP%3E%3CUL%3E%3CLI%3ESpeed%20boost%20is%20disabled%3C%2FLI%3E%3CLI%3ETabs%20are%20set%20to%20not%20sync%3C%2FLI%3E%3CLI%3EOn%20startup%20is%20set%20to%20open%20a%20new%20tab%3C%2FLI%3E%3C%2FUL%3E%3CP%3EIs%20there%20any%20additional%20place%20to%20tell%20the%20browser%20not%20to%20restore%20pages%2Ftabs%3F%26nbsp%3B%20%26nbsp%3B%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E(So%20far%20this%20is%20the%20only%20thing%20in%20new%20Edge%20that%20is%20seriously%20tempting%20me%20to%20return%20to%20Chrome...%20slowly%20driving%20me%20crazy.)%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Visitor

Edge boots with a restore pages message constantly, which doesn't go away unless you click on it.

 

There seem to be many options to disable it on chrome and chromium, but haven't found any that work for Edge Dev.

20 Replies
Hi,
there is an explanation here about this:
https://techcommunity.microsoft.com/t5/discussions/updated-dev-channel-update-to-88-0-705-9-is-live/...

there is no option currently in Edge to disable it.

@NewbUser This was bugging (pun intended) me too. I'm using Windows 10 with Edge, so YRMV, but this worked for me:

Open your browser. Click on the 3 dots all the way to the top right of the screen. 

Click on "Settings"

Click "System"

At the top right, turn off "Startup Boost"

 

If you have an old school hard drive, this might slow down startup of your browser a bit, but if you have a SSD, probably won't notice a difference.

@blackhillsken 

Hi,

Welcome to the community,

please take a moment and review the guidelines,

one of them is not cross-posting/duplicate posting, the other one is not bumping old threads.

Thank you

Hey there, I had to clean up this thread a bit but just to answer a few questions that came up in the (removed) comments: this issue should have been posted to a new thread or to a current thread not only from the forum rules but because the specific behavior you are experiencing is an emerging issue with a recent Stable build. The team working on Startup Boost is looking in to what is causing this currently, and yes the workaround is to disable Startup Boost. Please read the community rules and remember to be respectful. https://techcommunity.microsoft.com/t5/articles/microsoft-edge-insiders-community-guidelines/m-p/221...

@Alexandra-R - thanks for the suggestion, but unfortunately this does not work for me.
On restart/startup this popup constantly nags until it is clicked on (closed).
Running Version 89.0.774.76 (Official build) (64-bit)
Here's how my settings look for your information:

Globespy_0-1618329748457.png

 

I experience this too and my Startup Boost is not enabled. It seems simple enough to not display that message if you have the browser configured to not restore pages. This is of course different than assigning a default start page.

@FiveThumbs 

I have this problem also, on multiple devices. On all devices:

  • Speed boost is disabled
  • Tabs are set to not sync
  • On startup is set to open a new tab

Is there any additional place to tell the browser not to restore pages/tabs?    

 

(So far this is the only thing in new Edge that is seriously tempting me to return to Chrome... slowly driving me crazy.)

@aharown are you using shutdown.exe? I find that using this with an open Edge browser (I use -L and -F) causes the message. If you can close the browser before shutdown, the message does not seem to appear.

I have not experimented with taskkill, but that seems to be a way to close a program from the command line.
I'm not using shut down.exe. Just regular shutdowns from the start menu. But this really shouldn't matter. If Edge can't be closed in a normal Windows way without causing this irrelevant pop up, it's a bug and ought to be fixed.
Meanwhile if there's a registry hack or something that will make it go away I'd be happy to know.
Well, I know it gets real annoying with Restore Pages or Sessions. Instead of disabling it completely, what if the the "Restore pages or session" messages popup, but instead what if change it into some of timed box or slide over menu message appeared from three dot menu or top right corner and automatically after five to ten seconds or so it automatically disappear.
So, this way getting annoyed by it and waiting for to be closed how about let it disappear automatically.

@Soham1010 

It's unclear to me why it should be appearing at all.

If I crash with tabs open and want to get them back, I'll go to history and re-open them.

But this message pops up when no session has been abnormally terminated, so it's doubly irritating to not be able to turn it off.

I think the problem may be due in part to the use of extensions that keep Edge running in the background. I haven't had the opportunity to test this much, but it's a hypothesis: Edge doesn't shut down properly when certain extensions are installed, triggering the restore sessions message.

In any case, there is a registry 'hack' that has, so far worked for me. Information here: https://www.technipages.com/how-to-disable-restore-pages-prompt-in-microsoft-edge

@aharown 

 

There is no such registry option in Win 11, and this issue persists unfortunately.
Looks like Microsoft removed the registry entry, but didn't fix the problem. 
Crazy!

Globespy_0-1633395409738.png

 

That hack stopped working for me in Windows 10 also, so... it was probably only effective for an older version of Edge.

@NewbUser from reading this post it looks like there is not a baked in setting to do this or even a reg hack. However here is some powershell code I found that will close all edge processes, including open windows, gracefully. By gracefully I mean once the windows close and I reopen them I do not see the restore pages prompt. Also I tested this with Close-Process in powershell and found that the restore pages prompt still appears on reopening edge.

 

$edgeProcesses = Get-Process msedge -ErrorAction SilentlyContinue

if($edgeProcesses.Count -le 0)
{
    Write-Verbose -Verbose "No edge processes were found"
    #exit
}

while($edgeProcesses.Count -gt 0)
{
    foreach($process in $edgeProcesses)
    {
        $process.CloseMainWindow() | Out-Null
    }

    $edgeProcesses = Get-Process msedge -ErrorAction SilentlyContinue
}

As of recent updates, the problem has stopped occurring for me. There's still no setting as far as I can tell, but I no longer get nagged about restoring tabs every time I open the browser on a different device.

What recent updates are you referring to?
What build are you using?
I'm having the same issues and always update Edge.
I'm using 95.0.1020.53. It's possible that the problem was caused by one of my extensions and the offending extension updated. What I can report is that I used to see the popup every day and now maybe once a week.
I'm using the same build. What extension(s) did you think were causing the issue?