Intermittent Freezing of Edge Dev Build

%3CLINGO-SUB%20id%3D%22lingo-sub-1020203%22%20slang%3D%22en-US%22%3EIntermittent%20Freezing%20of%20Edge%20Dev%20Build%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1020203%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20all%3C%2FP%3E%3CP%3EBeen%20having%20a%20couple%20of%20issues%20with%20the%20past%20few%20versions%20of%20Edge%20Dev%20(currently%20on%26nbsp%3B%3CSPAN%3E80.0.334.2%20though%20has%20been%20happening%20for%20maybe%20a%20month%20prior).%20The%20pages%20seem%20to%20randomly%20freeze%20up%20and%20visually%20become%20unresponsive.%20This%20has%20mainly%20occurred%26nbsp%3Bon%20YouTube%20and%20I%20suspected%20a%20recent%20change%20by%20Google%2C%20though%20has%20now%20again%20happened%20on%20Apple's%20website%20which%20of%20course%20has%20no%20relation.%26nbsp%3B%3CBR%20%2F%3E%3CBR%20%2F%3EThe%20issue%20seems%20to%20happen%20while%20scrolling%20down%20on%20a%20page.%20For%20instance%20on%20YouTube%20I%20attempt%20to%20see%20the%20comments%20on%20a%20video%20and%20it%20freezes.%20Same%20with%20Apple%20when%20scrolling%20down%20to%20the%20specifications%20area.%26nbsp%3B%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EIt%20looks%20like%20the%20page%20has%20simply%20hung%2C%20though%20switching%20between%20tabs%20cannot%20be%20done.%20It%20locks%20up%20all%20menus%20and%20even%20the%20close%2C%20maximize%20and%20minimize%20buttons.%20It%20can%20be%20clicked%20behind%20though%3B%20I%20managed%20to%20navigate%20to%20another%20video%20when%20randomly%20clicking%20and%20was%20able%20to%20see%20the%20cursor%20change%20when%20hovering%20over%20the%20play%2Fpause%20button%20which%20was%20still%20responsive%2C%20just%20not%20visually.%20Alt%2BF4%20does%20the%20job%20to%20get%20out%20of%20it%2C%20and%20starting%20edge%20back%20up%20fixes%20it.%20Subsequent%20navigation%20to%20the%20page%20has%20no%20issue.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EI%20get%20the%20issue%20to%20come%20up%20anywhere%20between%20once%20a%20day%20and%20once%20a%20week.%20I%20frequently%20have%2020%20tabs%20open%20on%20the%20Microsoft%20Docs%20and%20random%20google%20searches%20which%20don't%20have%20an%20issue%2C%20therefore%20I%20believe%20it%20has%20to%20do%20with%20rendering%20elements%20like%20videos%20or%20phone-spinny-enlargy%20things%20that%20Apple%20love.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EI've%20been%20using%20the%20following%20plugins%3A%3CBR%20%2F%3EuBlock%20Origin%20-%20MS%20Store%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3EChannel%20Blocker%20-%20Google%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3EColorZilla%20-%20Google%3CBR%20%2F%3EKeeper%20-%20Google%3CBR%20%2F%3E%3CBR%20%2F%3EThe%20Channel%20Blocker%20has%20the%20ability%20to%20inject%20onto%20any%20page%20(I%20don't%20think%20its%20restricted%20to%20youtube.com)%20and%20display%20a%20X%20to%20block%20a%20channel%20so%20I've%20disabled%20that%20one%20to%20see%20if%20there's%20any%20change.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EI%20apologize%26nbsp%3Bif%20this%20is%20the%20incorrect%20place%20to%20report%20this%20issue%20or%20if%20the%20issue%20has%20been%20already%20reported.%20I%20did%20quickly%20search%20around%20a%20better%20reporting%20area%20and%20prior%20reports%20though%20couldn't%26nbsp%3Bcome%20up%20with%20anything.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3E%3CBR%20%2F%3ECheers%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1023413%22%20slang%3D%22pt-BR%22%3ERe%3A%20Intermittent%20Freezing%20of%20Edge%20Dev%20Build%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1023413%22%20slang%3D%22pt-BR%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F463090%22%20target%3D%22_blank%22%3E%40dangfanglednewtech%3C%2FA%3E%26nbsp%3B%20This%20problem%20has%20started%20to%20occur%20for%20many%20people%2C%20especially%20for%20those%20who%20have%20upgraded%20windows%20to%201909.%20The%20problem%20is%20in%20the%20GPU%20process%20by%20pressing%20shift%20%2B%20esc%20will%20open%20the%20edge%20manager%2C%20close%20the%20gpu%20process%20and%20the%20browser%20will%20respond%20again.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESo%20far%20there%20have%20been%20no%20corrections%20on%20this%2C%20the%20devs%20have%20not%20commented%20either%20and%20we%20are%20dark%20to%20know%20when%20the%20bug%20will%20be%20fixed.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1023523%22%20slang%3D%22en-US%22%3ERe%3A%20Intermittent%20Freezing%20of%20Edge%20Dev%20Build%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1023523%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F456802%22%20target%3D%22_blank%22%3E%40credulos%3C%2FA%3E%26nbsp%3BThank%20you%20for%20the%20response.%20I'm%20not%20sure%20why%20I%20couldn't%20find%20any%20information%20on%20it%20in%20that%20case.%20What%20you%20said%20does%20make%20sense%20as%20the%20issue%20appeared%20after%20installing%201909%20slow%20ring.%20I%20guess%20we'll%20have%20to%20wait%20and%20see%20for%20a%20permanent%20fix.%20In%20the%20mean%20time%20I%20will%20be%20sure%20to%20use%20that%20work%20around.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%26nbsp%3B%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1028324%22%20slang%3D%22en-US%22%3ERe%3A%20Intermittent%20Freezing%20of%20Edge%20Dev%20Build%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1028324%22%20slang%3D%22en-US%22%3EHi%2C%3CBR%20%2F%3EI've%20been%20having%20the%20same%20problem%20as%20well%3CBR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2FDiscussions%2FSuper-High-CPU-usage-on-Windows-i9-9900K-Edge-insider-Canary%2Fm-p%2F916094%22%20target%3D%22_blank%22%3Ehttps%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2FDiscussions%2FSuper-High-CPU-usage-on-Windows-i9-9900K-Edge-insider-Canary%2Fm-p%2F916094%3C%2FA%3E%3CBR%20%2F%3E%3CBR%20%2F%3EIntermittent%20Freezing%2C%20hanging%2C%20laggy%20scrolling%20and%20so%20on.%3CBR%20%2F%3Eadd%20high%20CPU%20usage%20to%20it%20too%3CBR%20%2F%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1029467%22%20slang%3D%22en-US%22%3ERe%3A%20Intermittent%20Freezing%20of%20Edge%20Dev%20Build%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1029467%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310193%22%20target%3D%22_blank%22%3E%40HotCakeX%3C%2FA%3E%26nbsp%3BThanks%20for%20the%20extra%20info.%20Whats%20interesting%20there%20is%20that%20I%20am%20also%20on%20an%20i7%207700K.%20Unfortunately%20though%20I%20haven't%20had%20the%20CPU%2FPower%20usage%20jump%20through%20the%20roof%20or%20at%20least%20not%20noticeably%20anyhow.%20The%20complete%20freeze%20up%20(of%20what%20I%20now%20understand%20is%20the%20GPU%20process)%20I've%20had%20though%20while%20its%20been%20working%20the%20scrolling%20and%20other%20input%20hasn't%20been%20laggy.%20I'm%20currently%20on%201%25%20CPU%2C%200.8%25%20GPU%20and%20Very%20Low%20power%20consumption%20with%2020%20tabs%2C%20one%20being%20YouTube%2C%20open.%20While%20randomly%20scrolling%20on%20this%20page%20it%20hits%205.5%25%20CPU%20and%2010%25%20GPU.%20Randomly%20scrolling%20on%20YouTube%20it%20hits%2012.2%25%20CPU%2C%26nbsp%3B%209.5%25%20GPU%20and%20Very%20High%20power%20consumption.%20Watching%20a%20video%20is%20a%20bit%20less%2C%208%25%20CPU%20and%20around%20the%20same%20GPU.%20A%20bit%20high%2C%20though%20not%20enough%20to%20be%20a%20noticeable%20issue.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI'll%20keep%20the%20original%20post%20updated%20if%20I%20get%20any%20more%20issues%20like%20what%20I%20originally%20reported%20or%20it%20exhibits%20symptoms%20similar%20to%20yours.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1029481%22%20slang%3D%22en-US%22%3ERe%3A%20Intermittent%20Freezing%20of%20Edge%20Dev%20Build%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1029481%22%20slang%3D%22en-US%22%3EYw%2C%20let%20me%20ask%20you%20something%20else%20that%20I%20suspect.%20have%20you%20also%20enabled%20Windows%20Defender%20application%20guard%20in%20your%20Windows%2010%3F%20how%20about%20Windows%20Sandbox%20feature%3F%3CBR%20%2F%3E%3CBR%20%2F%3EI'm%20asking%20that%20because%20when%20I%20fresh%20installed%20my%20Windows%2010%20insider%20build%20and%20didn't%20enable%20any%20additional%20features%2C%20I%20wasn't%20seeing%20that%20problem%20but%20when%20I%20enabled%20those%20features%2C%20after%20few%20days%2C%20the%20problem%20started%20happening.%3CBR%20%2F%3Eand%20when%20it%20happens%2C%20it%20happens%20in%20both%20Edge%20insider%20canary%20and%20Google%20chrome%20canary%2C%20makes%20me%20think%20there%20is%20something%20wrong%20with%20Chromium%20because%20when%20I%20try%20the%20same%20websites%20in%20Edge%20classic%2C%20they%20are%20smooth%20and%20without%20problem.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1029485%22%20slang%3D%22en-US%22%3ERe%3A%20Intermittent%20Freezing%20of%20Edge%20Dev%20Build%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1029485%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310193%22%20target%3D%22_blank%22%3E%40HotCakeX%3C%2FA%3E%26nbsp%3BI've%20had%20this%20issue%20occur%20over%20both%20Windows%20Defender%20(with%20everything%20turned%20on%20except%20for%20controlled%20folder%20access)%20and%20BitDefender%20TS.%20Both%20AV%20applications%20have%20never%20reported%20any%20actions%20taken%20and%20Event%20Viewer%20contains%20no%20relevant%20data.%20I've%20never%20enabled%20Sandbox.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1041544%22%20slang%3D%22en-US%22%3ERe%3A%20Intermittent%20Freezing%20of%20Edge%20Dev%20Build%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1041544%22%20slang%3D%22en-US%22%3E%3CP%3Eive%20been%20having%20this%20issue%20too.%26nbsp%3B%20i%20was%20thinking%20it%20was%20maybe%20related%20to%20ublock%20origin%20so%20ive%20removed%20that%20to%20do%20some%20testing.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Eapples%20website%20is%20one%20that%20freezes%20for%20me%20too.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Eedit%3A%26nbsp%3B%20nvm%2C%20its%20still%20happening.%26nbsp%3B%20killing%20the%20gpu%20process%20fixes%20it%20like%20reported.%26nbsp%3B%20really%20annoying.%26nbsp%3B%20hard%20to%20make%20it%20a%20daily%20driver%20if%20it%20keeps%20doing%20this.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
New Contributor

Hi all

Been having a couple of issues with the past few versions of Edge Dev (currently on 80.0.334.2 though has been happening for maybe a month prior). The pages seem to randomly freeze up and visually become unresponsive. This has mainly occurred on YouTube and I suspected a recent change by Google, though has now again happened on Apple's website which of course has no relation. 

The issue seems to happen while scrolling down on a page. For instance on YouTube I attempt to see the comments on a video and it freezes. Same with Apple when scrolling down to the specifications area. 

 

It looks like the page has simply hung, though switching between tabs cannot be done. It locks up all menus and even the close, maximize and minimize buttons. It can be clicked behind though; I managed to navigate to another video when randomly clicking and was able to see the cursor change when hovering over the play/pause button which was still responsive, just not visually. Alt+F4 does the job to get out of it, and starting edge back up fixes it. Subsequent navigation to the page has no issue.

 

I get the issue to come up anywhere between once a day and once a week. I frequently have 20 tabs open on the Microsoft Docs and random google searches which don't have an issue, therefore I believe it has to do with rendering elements like videos or phone-spinny-enlargy things that Apple love.

 

I've been using the following plugins:
uBlock Origin - MS Store

Channel Blocker - Google

ColorZilla - Google
Keeper - Google

The Channel Blocker has the ability to inject onto any page (I don't think its restricted to youtube.com) and display a X to block a channel so I've disabled that one to see if there's any change.

 

I apologize if this is the incorrect place to report this issue or if the issue has been already reported. I did quickly search around a better reporting area and prior reports though couldn't come up with anything.


Cheers

7 Replies
Highlighted

@dangfanglednewtech  This problem has started to occur for many people, especially for those who have upgraded windows to 1909. The problem is in the GPU process by pressing shift + esc will open the edge manager, close the gpu process and the browser will respond again.

 

So far there have been no corrections on this, the devs have not commented either and we are dark to know when the bug will be fixed.

Highlighted

@credulos Thank you for the response. I'm not sure why I couldn't find any information on it in that case. What you said does make sense as the issue appeared after installing 1909 slow ring. I guess we'll have to wait and see for a permanent fix. In the mean time I will be sure to use that work around.

 

Thanks  

Highlighted
Hi,
I've been having the same problem as well
https://techcommunity.microsoft.com/t5/Discussions/Super-High-CPU-usage-on-Windows-i9-9900K-Edge-ins...

Intermittent Freezing, hanging, laggy scrolling and so on.
add high CPU usage to it too
Highlighted

@HotCakeX Thanks for the extra info. Whats interesting there is that I am also on an i7 7700K. Unfortunately though I haven't had the CPU/Power usage jump through the roof or at least not noticeably anyhow. The complete freeze up (of what I now understand is the GPU process) I've had though while its been working the scrolling and other input hasn't been laggy. I'm currently on 1% CPU, 0.8% GPU and Very Low power consumption with 20 tabs, one being YouTube, open. While randomly scrolling on this page it hits 5.5% CPU and 10% GPU. Randomly scrolling on YouTube it hits 12.2% CPU,  9.5% GPU and Very High power consumption. Watching a video is a bit less, 8% CPU and around the same GPU. A bit high, though not enough to be a noticeable issue.

 

I'll keep the original post updated if I get any more issues like what I originally reported or it exhibits symptoms similar to yours.

 

Thanks

Highlighted
Yw, let me ask you something else that I suspect. have you also enabled Windows Defender application guard in your Windows 10? how about Windows Sandbox feature?

I'm asking that because when I fresh installed my Windows 10 insider build and didn't enable any additional features, I wasn't seeing that problem but when I enabled those features, after few days, the problem started happening.
and when it happens, it happens in both Edge insider canary and Google chrome canary, makes me think there is something wrong with Chromium because when I try the same websites in Edge classic, they are smooth and without problem.
Highlighted

@HotCakeX I've had this issue occur over both Windows Defender (with everything turned on except for controlled folder access) and BitDefender TS. Both AV applications have never reported any actions taken and Event Viewer contains no relevant data. I've never enabled Sandbox. 

Highlighted

ive been having this issue too.  i was thinking it was maybe related to ublock origin so ive removed that to do some testing.

 

apples website is one that freezes for me too.

 

edit:  nvm, its still happening.  killing the gpu process fixes it like reported.  really annoying.  hard to make it a daily driver if it keeps doing this.