Installing site as an app crashes Edge

New Contributor

Everytime I try to install a site as an app on macOS, Edge CPU spikes to 100% and stays there.


A newly created app shows up in Finder and on dock, but no UI of the app. I have to force quit Edge to continue working and launching the newly created app will terminate Edge.


I tried it on all channels and it's the same behavior. I'm on macOS Catalina.

4 Replies


I just tested Microsoft Edge Version 83.0.472.0 (Official build) Canary (64-bit)

on Mac 10.15.4, installed Instagram as an app and it worked without crashing.

@Kris Zhou Thanks for reaching out, and welcome to our Microsoft Edge Insider's community!


We've recently opened a bug for unexpectedly high CPU usage on mac, so there might be some overlap there. However, I want to make sure that this isn't a separate issue relating to PWAs; if you haven't yet, can you please submit detailed feedback and diagnostic data through the browser? This would really help our devs pinpoint what's happening. (And if you mention "Fawkes" in the comment, then tell me after you submit it, I'll keep a lookout and  make sure it goes to the right team.)



Fawkes (they/them)
Project & Community Manager - Microsoft Edge

I did submit a feedback yesterday, but I think I've figured out what's causing the issue, without knowing why it's causing it.

I was using a Dock replacement app called uBar on macOS, which functions similar to the native Dock with some enhanced abilities. The "Install site as app" process might have some conflicts with the system hooks uBar uses to query active apps, especially Finder. After I switch back the the native Dock, everything works fine.

I'll report this to uBar's development team as well.

Thank you for your help digging into this. @Deleted @HotCakeX
You're welcome, and also good job on finding it, that must be the reason, the custom dock :)