IE Mode Problem

Occasional Contributor

I'm running the latest Dev-Build on a Windows 1903, have both the IE Mode flags enabled, but when I try to switch a page into IE Mode, I only at the notification, that I have to re-install MS Edge with admin privileges.


So, yes, I've tried that. I've also tried *running* MS Edge elevated priviledges but to no avail.


Does anyone else have these issues?


Best regards, Michael

14 Replies
same issue on my side

@michaelketting it seems few updates are required on top 1903 according :

  • Windows 10, version 1903 with the latest cumulative updates (KB4503293 or higher) and security update KB4501375 or higher
  • Windows 10, version 1809 with latest cumulative update (KB4509479 or higher)

did you already install them?

@jcnicoudThanks! I've downloaded and installed the latest update for 1809 (KB4509479) and now it works! 

What about Windows Server 2012 and 2016? There I have the same issue. What's the minimium requirements on server side?

@michaelketting And what about Windows 10 LTSC Enterprise 2019 (version 1607)? I have the same problem with IE mode.

Best regards

@jcnicoud  I am on 1809 with a higher CU than what is mentioned (KB4507469 (OS Build 17763.615)) and I am still getting the same error stating it can't open in IE mode and is asking me to try reinstalling edge with admin privileges. I am going to try this on one of my 1903 machines to see if I get the same issue but wanted to see if there was something else I am missing. Should I maybe try to uninstall and reinstall the Edge dev build? 

@stesch79  According to a Microsoft Support Case I have opened, the following minimium prerequisites are valid for server to run IE mode properly: 


Window Server 2019: 17763.593 from July 2019


Below this OS and build, IE mode will nor work seamless.


Thank you for the tip. Yes, updates are missing when they shouldn't. Am working on fixing this now.

I also have to appologize, for not repsonding sooner, but it turns out you have to actively subsribe to a thread you created and don't just get notificiation mails when there's activity. My bad!

Okay, I've now installed the latest updates:
OS Version: 10.0.18362 N/A Build 18362
[01]: KB4506991
[02]: KB4497727
[03]: KB4503308
[04]: KB4509096
[05]: KB4497464

I'm using the --ie-mode-test flag (, but Internet Explorer still opens as a separate Window.

The correct way and the way Microsoft expects users to use the IE mode is through group policy. since it's a feature that is rarely used and only enterprises and those who are Forced to use IE will use it then there is no problem with group policy deployment.
for now, if you need IE then use IE inside Windows, there is no news at all about it being removed.

@HotCakeXI'm sorry but there's documentation (well, blog posts, mostly) out there to use this feature, there's flags within Internet Explorer to use this feature, there's options the actual UI to use this feature, so I expect to be able to use it without out much fuss.


As to why it's important: Right now, Edge is in prerelease and it's important to test that the concept of IE mode works for applications that are relying on it and I like to be able to do so without much fuss and ceremony. It is, for instance, not practical to reserve a VM and/or a dedicated web application deployment soley for testing compatibility of your application with IE mode. And yes, some applications must be evaluated with and without IE mode because you don't know which way customers will swing.

The UI button is gone.
yes the IE mode should be tested and this is how Microsoft says it should be done:

It's good that they removed the UI features, 99.9% of users Don't need IE mode. if they needed then Google Chrome wouldn't be the top most used browser ;)
also using Group Policy is very straightforward and easy.
I have the same issue with Internet Explorer opening in a separate window

This has just started happening for me, since installing the latest 1903 CU and Edge Dev release only yesterday. Prior to that, IE Mode has always worked fine.


The thing is we are running at Systems Level as the Executable is within the Program Files folder. Also GPO is configured correctly!


Any ideas?