iCloud website not working

Brass Contributor

On Version 80.0.355.0 (Official build) canary (64-bit) the iCloud site does not work.  image.png


Browser errors:

POST <a href="" target="_blank"></a> 421 (Misdirected Request)

Refused to display '<a href="" target="_blank"></a>


Website works fine on Beta build.

6 Replies
best response confirmed by causefx (Brass Contributor)

Hi @causefx 

I just tried logging in, Version 80.0.355.0 (Official build) canary (64-bit) no problem




try clearing browser data



or are you trying to do any special task in there that causes the error?

You are correct, Trying incog worked. Not sure why I didnt try that first. Thanks!


Nailed down the issue.  It was my PIA browser extension.  I had Disable Website Referrer on which cause the site to break... Sorry


Oh hah, thanks for sharing it, could be useful to know that these things can break some websites! good job

@causefx Thanks for posting this. I didn't think this extension would be the culprit as I wasn't logged into a PIA server. The extension is breaking iCloud even if you're logged out of the PIA servers... Looks like they made a change to the extension where certain features are enabled all the time, regardless if you're logged into a PIA server or not:


"Enabled settings are now always active whether you are connected to a region or not, with the exception of PIA MACE™ which is only active when you are connected to a region."

@causefx Thank you. My PIA settings were blocking iCLOUD for me too and your solution worked.