Hulu works on Dev build but not Canary

New Contributor

I have been using the Dev build for several months and have not really noticed any significant problems that were not addressed. I decided to try the Canary build on another computer yesterday, and was surprised that Hulu would not play back my videos. The video starts, and then I get a RUNUNK13 error code.


I searched the Hulu support pages and could find nothing on that error. I tried their troubleshooting steps, and even contacted support. I did some further troubleshooting based on one of their support pages,, and it said to try an incognito or private window. That did work and my video played, but the agent at Hulu had also did a resynch on my account about the same time. I try it now, and it does not work in a new private window.


My current Canary build is Version 82.0.437.0 (Official build) canary (64-bit) and my current Dev build is Version 82.0.432.3 (Official build) dev (64-bit)



5 Replies



Try enabling these flags edge://flags/




Thanks @HotCakeX 


I appreciate the screenshot as well.


I had mixed results. It worked on one or two videos, but the majority still got a RUNUNK13 error after they started to play.

You're welcome, well I have an idea, try disabling one of them and enabling the other. I don't remember exactly which one should be disabled and which one enabled but try every combination

That worked @HotCakeX 


Saying to try every combination got me to thinking.


I gave it a try, and had the same results with either one enabled and the other set back at default.


I then went in and enabled one, and disabled the other. In this case, Enabling Widevine DRM and Disabling PlayReady DRM for Windows 10 worked.

Nice, happy to hear :)