Huge, pixeled font on some websites

New Contributor

Hi

With the Edge browser the font of some sites is displayed huge, wired and completely unreadable.
When I open the same URLs with Firefox everything is displayed as expected

Edge-Browser-Pixeled-Website.png (1828×993) (enertech.ch)

Firefox-Browser-Nice-Website.png (1913×1024) (enertech.ch)

Same happens also with the following and several other websites.

Digital Banking Software & Services | ementexx

 

Thank you for any suggestion.

Regards

Stefan

6 Replies

Your provided site is displayed correctly in my browser Edge 105. Try resetting your browser and see if the sites load ok.

@JakeXavier 
I did a reset with of my
Version 105.0.1343.53 (Offizielles Build) (64-Bit)
and also tried browsing as guest.
No success. The pages look will awful. Because they look like this on the Notebook screen with a resolution of 3456x2160 and the external screens 1920x1080 I guess it is a browser/windows issue.
But I ran out of options where to look at.

@StefanEgger 

Hi, check in the Edge settings the default zoom I have 80%, but you can set less, then go to the appearance settings and there at the bottom you can set size font - most sites respect these settings.

@Andrzej1 

Reducing zoom makes the font smaller but it is still pixeled.

This is another website which is displayed with odd font with zoom 80%

Edge-Browser-Pixeled-Website-zoom80.png (3268×2002) (enertech.ch)

It is strange because only about 2% of the websites I browse have this issue. 98% are displayed perfectly fine.

I also checked if the fonts used on the website is installed on the computer.

@StefanEgger This might be to do with the DPI setting used within Windows itself: some apps don't scale correctly if you use non-standard settings (anything other-than 125%, 150% or 200%, e.g. 105%).  In Windows 10, go into the Settings app, then System, then Display and under "Scale and layout" see what is selected in the first dropdown menu.

 

You can also try adjusting the DPI settings on the Edge browser itself.  Browse into one of these folders:

C:\Program Files\Microsoft\Edge\Application

C:\Program Files (x86)\Microsoft\Edge\Application

and then right-click on the "msedge.exe" file, then go to Properties.  Then click the Compatibility tab and then click the [Change high DPI settings] button.  Make a change there, then log out of your Windows session, then back in, and see if it's made a difference.  If not, keep trying different settings there and see if any of them fix the issue.

@dftf-wip 

Hi, I use custom scaling in Windows and have never had a problem, of course I have experience in this, so for each computer I have different settings, but this is rather a site configuration error, which, is outdated.