How to Unhide (vs) disable/enable my Extensions in Edge?

Brass Contributor

I just installed Edge. I'm about to uninstall it. Before I do, I thought I would make a post here. With Chrome, I can HIDE or UNHIDE an extension with ease. When I hide an extension in Edge, it supposedly goes to the Menu. I don't see no Menu or Menu bar. I see a section called Extensions, but that's not a Menu nor does it have any option to unhide an extension. Once you hide an extension, I can't unhide it. I can toggle the extension (enable or disable) but that also won't bring back the extension OR it's functionality. 

15 Replies
Right click go to menu -> hide
open the ... menu right click on the icon of the extension move to toolbar -> unhide



Edge is different than Chrome,

Hide and Unhide buttons have different labels and behavior here.


you can move an extension's icon from Edge toolbar to the ellipsis menu (the 3-dots), and call it hiding.


so click on (...) menu button at top-right side of the browser




at the top, you will find the extensions that you moved to the menu




right-click on them and choose "Move to the toolbar"



You can also use drag & drop to move it to the toolbar

Thanks, I tried doing that. There is no way I can move the extension icons anywhere except on the same "line" to reorder. As you seem to have this option, I believe the Windows7/ 8.1 versions behave differently than the Windows 10 version.

I also understand that Edge is now using Chrome's (Chromium)'s engine and most everything is identical with a few differences including cosmetic ones.
Sorry no. I don't have that option in Win 8.1 Edge version.
Can you please attach a screenshot of how your Edge looks like?

@HotCakeXHi. Unfortunately no. I uninstalled it. It was running in the background and it was almost 500 MB in size after it did its thing. I've gone back to Chrome and Firefox. I might try Opera as it's also Chromium based.

Lol okay good luck
Great help with these latest screenshots. Thanks


HI, I just found a solution for this. Right click on the extension you want to move or hide it and then choose "Move to the Menu" option.

You're welcome :)


My three dots menu has no space above it where the "hide from menu" extension icons should (and used to) appear. 

The top row of the three dots menu is "new tab."

So now, hidden extension icons are really hidden. Can't find them anywhere.


This is a recent problem. I'm using  92.0.902.55. 


The way you hide and unhide now is by left clicking the puzzle piece icon on the toolbar. There's an eye icon next to each for making visible/not visible.
In short, it's no longer in the three dots menu at all.


Hey, not sure if this is what anyone's looking for but I had the problem on hiding my extensions but I figured out how to.


1. Press the 3 dots. 

2. Go to Settings > Apperance 

3. Scroll down until you see the menus for Select which buttons to show on the toolbar:

4. Make sure you turn on the Show extensions button

5. You will have the puzzle icon up on your toolbar

6. Now you can easily right-click on any extension that you want to hide


Hope this helps anyone out there! :smile:





This is the **only** way this worked for me. (on macos)