How to NOT auto-sign in to all MS Sites

New Contributor

I notice now that staying signed in to Edge automatically signs me in to OneDrive, OneNote, etc.


Although convenient, I do NOT want this feature. I clear all cookies on exit and use a password manager. I only want to log into Edge to sync favorites and extensions.


How can I prevent this behavior, or at the very least sign out of Edge every time I close my browser?

4 Replies



I will list a couple of methods for you with screenshots, that I hope can help you.


First has to do with your profile settings:

This will take you to this pagepasswords.PNG

  • Turn off Sign in automatically


You can do for sites or sources individually also by:

This is what the top of the page will look like


  • You can go through Cookies and many other options
  • Some of the options allow you to clear data whenever you exit the browser 
  • You can block or add individual sites also through a lot of these options

Hope this helps,




Thank you for your help
I think it's great how the password handing works in Edge Canary, great work

@V-FRROME Thanks for your help, but none of those suggestions work.


I've already tried all of those settings, but if I stay logged into Edge, I am automatically logged into OneDrive - even after I've manually cleared all cookies. This is unacceptable behavior for a browser for me.


This is precisely why I hated logging into Chrome because I did not want to automatically log into every Google service automatically. MS seems to have aped this behavior.


An option to log out of the browser would suffice. For now, I'll stick to Firefox because it is a seperate account from both my MS and Google accounts.

best response

@tpaladin I work on the Edge product team. I totally understand that you prefer not to be auto signed in, let me try to help get you to that state.


Today, Edge auto signs into sites using browser to website single sign on. That is, if you sign into Edge - you get auto signed into sites. To disable this behavior, you can sign out of any microsoft site and we will not auto sign you back in the next time. The way we achieve this is by setting a cookie (IgnoreCAW for the domain 


Since you're clearing cookies on exit, this sign out state cookie is getting cleared and you're getting browser to web SSO the next time around. Could you try to clear all cookies besides the ones associated with If you do this, you should see that you will stay signed out of microsoft sites