How to disable automatic video playback on web pages?

Not applicable

What should I do to get the edge browser to disable CNN's web page from automatically playing video? I hate video news so much, not only is it very traffic consuming, but it's destructive to the news reading experience.

In addition, there is no option for autoplaying videos inside EDGE://flags, which is odd since chrome provides the relevant option inside chrome://flags.

8 Replies

@Deleted Thanks for reaching out.


The good news is that this should be an easy setting change. We addressed this on our What's New page a little while ago, so you should be able to follow the steps below:




Hopefully this addresses your question. If not, just let us know and we'd be happy to look into this further.


Fawkes (they/them)
Project & Community Manager - Microsoft Edge


best response

@Deleted @Deleted 

Unless I am missing something, this feature was moved to require a flag that is still present in the Stable channel, but was removed in more recent builds. It is not present in my Canary or Dev channel installations.


See this post from April 23:


It also appears in the Top Feedback post as Planned, with no date in the May 28 post: with a snip for the entry showing "on this list" for 40 weeks at that time


I hope I am missing something, but look forward this feature coming back in the future.



Thank you for your reply.
I've found #edge-autoplay-user-setting-block-option in the stable version.
In addition, I found that directly using uBlock Origin's feature to block all scripts on the site can directly and effectively block the page from automatically playing the video.Snipaste_2020-06-05_08-03-01.png

@Deleted There is no such option of Block in autoplay. Also, there is no flag to enable it. Something is wrong with this canary build. Many flags are missing like streaming only one media at a time, global media controls work but the video selection pane doesn't appear anymore while playing videos, native notifications option is missing.

@Deleted @sauravyad500 @ms4132 


Thank you all for sharing your thoughts, and yes, you are correct: the flag has since been disabled. The good news is that this thread prompted an internal discussion, and one of our engineering teams is looking into potential next steps for blocking autoplay. We appreciate the feedback!


Fawkes (they/them)
Project & Community Manager - Microsoft Edge

@DeletedUnfortunately they took this feature out of the most current release of Edge. :(


Thank you for all your hard work!

Disallowing a block on video is just bush league.  This has to change (just too annoying) or I will be forced to end my time with Edge.