How to always allow specific external protocols

%3CLINGO-SUB%20id%3D%22lingo-sub-1226498%22%20slang%3D%22en-US%22%3EHow%20to%20always%20allow%20specific%20external%20protocols%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1226498%22%20slang%3D%22en-US%22%3E%3CP%3ESince%20the%20new%20update%20(I%20have%26nbsp%3B%20Version%2082.0.439.1%20(Official%20build)%20dev%20(64-bit)%20)%2C%20the%20solution%20from%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fdiscussions%2Fhow-to-always-allow-specific-local-protocol%2Fm-p%2F1219109%23M26051%22%20target%3D%22_self%22%3Ehere%3C%2FA%3E%20doesn't%20work%20anymore.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20checked%20my%20Preferences%20file%20in%20AppData%5CLocal%5CMicrosoft%5CEdge%20Dev%5CUser%20Data%5CDefault%20and%20the%20exclusion%20rule%20is%20still%20there%20(%22protocol_handler%22%3A%7B%22excluded_schemes%22%3A%7B%22vscode%22%3Afalse%2C%22zotero%22%3Afalse%7D%7D%20)%20%2C%20but%20each%20time%20I%20open%20one%20of%20the%20specified%20protocol%2C%20I%20am%20asked%20to%20confirm%20that%20I%20want%20to%20open%20it.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHow%20to%20fix%20this%20%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20set%26nbsp%3BExternalProtocolDialogShowAlwaysOpenCheckbox%20policy%20to%20true%3C%2FP%3E%3CP%3EI%20have%20enable%26nbsp%3B%3CA%20href%3D%22edge%3A%2F%2Fflags%2F%23edge-exclude-schemes-per-origin%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Eedge%3A%2F%2Fflags%2F%23edge-exclude-schemes-per-origin%3C%2FA%3E%3C%2FP%3E%3CP%3EI%20have%20edit%20my%20preferences%20files%20as%20I%20describe%20here%20%3A%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fdiscussions%2Fhow-to-always-allow-specific-local-protocol%2Fm-p%2F1219109%23M26051%22%20target%3D%22_blank%22%3Ehttps%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fdiscussions%2Fhow-to-always-allow-specific-local-protocol%2Fm-p%2F1219109%23M26051%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1502772%22%20slang%3D%22en-US%22%3ERe%3A%20How%20to%20always%20allow%20specific%20external%20protocols%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1502772%22%20slang%3D%22en-US%22%3EDid%20you%20ever%20find%20a%20solution%3F%20We%20would%20like%20to%20configure%20this%20for%20all%20of%20our%20users%20for%20Teams%2C%20Zoom%2C%20and%20other%20protocols.%3C%2FLINGO-BODY%3E
Highlighted
Contributor

Since the new update (I have  Version 82.0.439.1 (Official build) dev (64-bit) ), the solution from here doesn't work anymore.

 

I checked my Preferences file in AppData\Local\Microsoft\Edge Dev\User Data\Default and the exclusion rule is still there ("protocol_handler":{"excluded_schemes":{"vscode":false,"zotero":false}} ) , but each time I open one of the specified protocol, I am asked to confirm that I want to open it.

 

How to fix this ?

 

 

I have set ExternalProtocolDialogShowAlwaysOpenCheckbox policy to true

I have enable edge://flags/#edge-exclude-schemes-per-origin

I have edit my preferences files as I describe here : https://techcommunity.microsoft.com/t5/discussions/how-to-always-allow-specific-local-protocol/m-p/1...

 

2 Replies
Highlighted
Did you ever find a solution? We would like to configure this for all of our users for Teams, Zoom, and other protocols.
Highlighted

@Daniel Ratliff I haven't found a solution yet.