Group Policy "Default Settings" are not applying on First Launch New Users

%3CLINGO-SUB%20id%3D%22lingo-sub-1457318%22%20slang%3D%22en-US%22%3EGroup%20Policy%20%22Default%20Settings%22%20are%20not%20applying%20on%20First%20Launch%20New%20Users%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1457318%22%20slang%3D%22en-US%22%3E%3CP%3EWe%20have%20added%20the%20following%20Default%20Settings%20via%20GPO.%20Users%20can%20Change%3C%2FP%3E%3CP%3EHome%20Page%3C%2FP%3E%3CP%3ESet%20new%20Tab%20Page%20to%20Home%20Page%3C%2FP%3E%3CP%3EShow%20Home%20Button%3C%2FP%3E%3CP%3EPages%20to%20open%20on%20Startup.%3C%2FP%3E%3CP%3E%3CSPAN%3EEdge%20Version%2083.0.478.45%3C%2FSPAN%3E%3C%2FP%3E%3CP%3EThe%20ONLY%20GPO%20that%20is%20actually%20setting%20is%20%22show%20home%20button%22.%20The%20rest%20EXIST%20in%20the%20settings%20as%20%22recommended%20by%20your%20organization%22%20but%20they%20are%20absolutely%20NOT%20setting%20as%20%22default%20setting%22.%3CBR%20%2F%3E%3CBR%20%2F%3EThe%20entire%20point%20of%20this%20was%20to%20set%20the%20Settings%20that%20are%20DEFAULT%20and%20then%20let%20users%20choose%20but%20that%20doesn't%20seem%20to%20work%3F%3CBR%20%2F%3E%3CBR%20%2F%3EI%20can%20confirm%20that%20the%20GPO%20Registry%20keys%20below%20are%20applied.%3CBR%20%2F%3E%3CBR%20%2F%3E%3C%2FP%3E%3CP%3EPreferences%20-%20Windows%20Settings%20-%20Registry%3C%2FP%3E%3CP%3ERegistry%20item%3A%20ShowHomeButton%3C%2FP%3E%3CP%3EPropertiesHive%20HKEY_CURRENT_USER%3C%2FP%3E%3CP%3EKey%20path%20Software%5CPolicies%5CMicrosoft%5CEdge%5CRecommended%3C%2FP%3E%3CP%3EValue%20name%20ShowHomeButton%3C%2FP%3E%3CP%3EValue%20type%20REG_DWORD%3C%2FP%3E%3CP%3EValue%20data%200x1%20(1)%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ERegistry%20item%3A%20RestoreOnStartup%3C%2FP%3E%3CP%3EPropertiesHive%20HKEY_CURRENT_USER%3C%2FP%3E%3CP%3EKey%20path%20Software%5CPolicies%5CMicrosoft%5CEdge%5CRecommended%3C%2FP%3E%3CP%3EValue%20name%20RestoreOnStartup%3C%2FP%3E%3CP%3EValue%20type%20REG_DWORD%3C%2FP%3E%3CP%3EValue%20data%200x4%20(4)%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ERegistry%20item%3A%20PasswordManagerEnabled%3C%2FP%3E%3CP%3EPropertiesHive%20HKEY_CURRENT_USER%3C%2FP%3E%3CP%3EKey%20path%20Software%5CPolicies%5CMicrosoft%5CEdge%5CRecommended%3C%2FP%3E%3CP%3EValue%20name%20PasswordManagerEnabled%3C%2FP%3E%3CP%3EValue%20type%20REG_DWORD%3C%2FP%3E%3CP%3EValue%20data%200x0%20(0)%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ERegistry%20item%3A%20HomepageLocation%3C%2FP%3E%3CP%3EPropertiesHive%20HKEY_CURRENT_USER%3C%2FP%3E%3CP%3EKey%20path%20Software%5CPolicies%5CMicrosoft%5CEdge%5CRecommended%3C%2FP%3E%3CP%3EValue%20name%20HomepageLocation%3C%2FP%3E%3CP%3EValue%20type%20REG_SZ%3C%2FP%3E%3CP%3EValue%20data%20%3CA%20href%3D%22https%3A%2F%2Fgww.gov.bc.ca%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fo%3C%2FA%3Eurhomepage%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ERegistry%20item%3A%20HomepageIsNewTabPage%3C%2FP%3E%3CP%3EPropertiesHive%20HKEY_CURRENT_USER%3C%2FP%3E%3CP%3EKey%20path%20Software%5CPolicies%5CMicrosoft%5CEdge%5CRecommended%3C%2FP%3E%3CP%3EValue%20name%20HomepageIsNewTabPage%3C%2FP%3E%3CP%3EValue%20type%20REG_DWORD%3C%2FP%3E%3CP%3EValue%20data%200x1%20(1)%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ERegistry%20item%3A%20AutofillCreditCardEnabled%3C%2FP%3E%3CP%3EPropertiesHive%20HKEY_CURRENT_USER%3C%2FP%3E%3CP%3EKey%20path%20Software%5CPolicies%5CMicrosoft%5CEdge%5CRecommended%3C%2FP%3E%3CP%3EValue%20name%20AutofillCreditCardEnabled%3C%2FP%3E%3CP%3EValue%20type%20REG_DWORD%3C%2FP%3E%3CP%3EValue%20data%200x0%20(0)%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ERegistry%20item%3A%20AutofillAddressEnabled%3C%2FP%3E%3CP%3EPropertiesHive%20HKEY_CURRENT_USER%3C%2FP%3E%3CP%3EKey%20path%20Software%5CPolicies%5CMicrosoft%5CEdge%5CRecommended%3C%2FP%3E%3CP%3EValue%20name%20AutofillAddressEnabled%3C%2FP%3E%3CP%3EValue%20type%20REG_DWORD%3C%2FP%3E%3CP%3EValue%20data%200x0%20(0)%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ERegistry%20item%3A%201%3C%2FP%3E%3CP%3EPropertiesHive%20HKEY_CURRENT_USER%3C%2FP%3E%3CP%3EKey%20path%20Software%5CPolicies%5CMicrosoft%5CEdge%5CRecommended%5CRestoreOnStartupURLs%3C%2FP%3E%3CP%3EValue%20name%201%3C%2FP%3E%3CP%3EValue%20type%20REG_SZ%3C%2FP%3E%3CP%3EValue%20data%20-ERR%3AREF-NOT-FOUND-https%3A%2F%2Fourhomepage%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1457808%22%20slang%3D%22en-US%22%3ERe%3A%20Group%20Policy%20%22Default%20Settings%22%20are%20not%20applying%20on%20First%20Launch%20New%20Users%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1457808%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F310254%22%20target%3D%22_blank%22%3E%40lforbes%3C%2FA%3E%26nbsp%3B%3CBR%20%2F%3E%3CBR%20%2F%3ESo%20it%20turns%20out%20that%20the%20Recommend%20Settings%20do%20NOT%20apply%20if%20you%20have%20the%20First%20Run%20experience%20enabled.%20It%20just%20plows%20right%20over%20it.%20You%20have%20to%20set%20the%20new%20GPO%20setting.%20I%20just%20added%20the%20registry%20key%20here%20for%20people.%3CBR%20%2F%3EHive%20HKEY_LOCAL_MACHINE%3CBR%20%2F%3EKey%20path%20SOFTWARE%5CPolicies%5CMicrosoft%5CEdge%3CBR%20%2F%3EValue%20name%20HideFirstRunExperience%3CBR%20%2F%3EValue%20type%20REG_DWORD%3CBR%20%2F%3EValue%20data%200x1%20(1)%3CBR%20%2F%3E%3CBR%20%2F%3EWe%20also%20had%20to%20add%20this%20to%20stop%20the%20auto%20sign%20in%20for%20the%20settings%20to%20stick.%3CBR%20%2F%3E%5BHKEY_CURRENT_USER%5CSoftware%5CPolicies%5CMicrosoft%5CEdge%5D%3CBR%20%2F%3E%22ConfigureOnPremisesAccountAutoSignIn%22%3Ddword%3A00000000%3CBR%20%2F%3E%3CBR%20%2F%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Contributor

We have added the following Default Settings via GPO. Users can Change

Home Page

Set new Tab Page to Home Page

Show Home Button

Pages to open on Startup.

Edge Version 83.0.478.45

The ONLY GPO that is actually setting is "show home button". The rest EXIST in the settings as "recommended by your organization" but they are absolutely NOT setting as "default setting".

The entire point of this was to set the Settings that are DEFAULT and then let users choose but that doesn't seem to work?

I can confirm that the GPO Registry keys below are applied.

Preferences - Windows Settings - Registry

Registry item: ShowHomeButton

PropertiesHive HKEY_CURRENT_USER

Key path Software\Policies\Microsoft\Edge\Recommended

Value name ShowHomeButton

Value type REG_DWORD

Value data 0x1 (1)

 

Registry item: RestoreOnStartup

PropertiesHive HKEY_CURRENT_USER

Key path Software\Policies\Microsoft\Edge\Recommended

Value name RestoreOnStartup

Value type REG_DWORD

Value data 0x4 (4)

 

Registry item: PasswordManagerEnabled

PropertiesHive HKEY_CURRENT_USER

Key path Software\Policies\Microsoft\Edge\Recommended

Value name PasswordManagerEnabled

Value type REG_DWORD

Value data 0x0 (0)

 

Registry item: HomepageLocation

PropertiesHive HKEY_CURRENT_USER

Key path Software\Policies\Microsoft\Edge\Recommended

Value name HomepageLocation

Value type REG_SZ

Value data https://ourhomepage

 

 

Registry item: HomepageIsNewTabPage

PropertiesHive HKEY_CURRENT_USER

Key path Software\Policies\Microsoft\Edge\Recommended

Value name HomepageIsNewTabPage

Value type REG_DWORD

Value data 0x1 (1)

 

Registry item: AutofillCreditCardEnabled

PropertiesHive HKEY_CURRENT_USER

Key path Software\Policies\Microsoft\Edge\Recommended

Value name AutofillCreditCardEnabled

Value type REG_DWORD

Value data 0x0 (0)

 

Registry item: AutofillAddressEnabled

PropertiesHive HKEY_CURRENT_USER

Key path Software\Policies\Microsoft\Edge\Recommended

Value name AutofillAddressEnabled

Value type REG_DWORD

Value data 0x0 (0)

 

Registry item: 1

PropertiesHive HKEY_CURRENT_USER

Key path Software\Policies\Microsoft\Edge\Recommended\RestoreOnStartupURLs

Value name 1

Value type REG_SZ

Value data https://ourhomepage

1 Reply
Highlighted

@lforbes 

So it turns out that the Recommend Settings do NOT apply if you have the First Run experience enabled. It just plows right over it. You have to set the new GPO setting. I just added the registry key here for people.
Hive HKEY_LOCAL_MACHINE
Key path SOFTWARE\Policies\Microsoft\Edge
Value name HideFirstRunExperience
Value type REG_DWORD
Value data 0x1 (1)

We also had to add this to stop the auto sign in for the settings to stick.
[HKEY_CURRENT_USER\Software\Policies\Microsoft\Edge]
"ConfigureOnPremisesAccountAutoSignIn"=dword:00000000