Grammarly extension doesn't work

Regular Contributor

1- Install Grammarly extension

2- Login to your Grammarly account

3- Grammarly behaves as if you aren't logged in. If you click on the extension icon, you get a message that says "Grammarly is active, but key features are missing -- Sign up now to unlock the following..." as per attached image

 

PS. I have checked and double checked, the extension is activated. I have also tried uninstalling and reinstalling the extension. I have also logged out and logged back in, all to no avail.

 

 

8 Replies
Have you tried it on chrome? Maybe there is some problem in extension itself.

@Deleted -- It works fine in Chrome, Vivaldi and Brave. However, you are on to something. I was using the extension from the Microsoft store. The Google store version seems to be working fine.

yeah, I never use any extension from microsoft store, They are buggy and works like sh*t.
Chrome webstore have the best extensions.

@Balaje_Krishnan - Just a heads up that my Grammarly started working this morning (04/26) in Edge Dev release. Since Dev did not update today, I would presume that the Grammarly extension was updated in some way. At any rate, some form of spell checking was all I was waiting on to make Edge Dev my primary browser.

@Darrell Shannon - thanks for reporting back!

It works fine with me. Grammarly 

 

You can find any Grammarly tutorial which will help you out :) 

This extension is broken again on 84.0.495.2.  

@rollo1002 - Are you still facing problems with Grammarly? Will be able to provide more details/steps on what exactly is broken? 

Thanks!!