GPO to Open Files on the new Edge WITHOUT saving first. REQUIRED for Kiosks (Always Open in System)

Contributor

We have thousands of Health Kiosks running in hospitals that are running IE 11.
We want to upgrade them to Edge Chromium.

We have tons of Group Policies restricting the "saving" of documents outside the "temporary internet files" which is the ONLY allowed location.

Users are trying to fill out forms in PDF. They are required to use Adobe PDF for the advanced features. 

In IE they could click "OPEN" and it would download into the Temporary Internet Files hidden folder and then Open in Adobe PDF (not active x but full Adobe PDF program).

In Edge it seems to want to force a download and does not give an option to open in the Temporary Internet Files and allow them to Edit the form and then print?

Please setup Edge to NOT try and Save but allow users to "open" like IE does.

Edge has the option to "Always Open in PDF Viewer" but it doesn't appear to be a group policy.
What is the registry key for it?  I Found open_pdf_in_system_reader":true} in the preferences file but that is useless to me.

When I set Always Open PDF Files Externally it won't download them to Temporary Internet Files. If i unlock c:\ it will download but then when I click on it, it says "Cannot open PDF in Edge - Disable PDF files externally" even though Adobe Reader is the Default PDF handler.

I have even setup the Default Download Directory to force it to Temporary Internet Files and NEVER ask user where to save and it still pops up trying to save to Downloads or Desktop which are blocked.

7 Replies

@lforbes 

 

Have you checked the new policies in Edge Beta?

 

https://docs.microsoft.com/en-us/deployedge/microsoft-edge-relnote-beta-channel

AutoOpenFileTypes
AutoOpenAllowedForURLs

Those might do what you want, although its unclear if the Auto Open feature puts the files in a temp location...

 

 

Just to answer, the AutoOpenFileTypes was working in my case with jnlp files, the files are not downloaded, they are automatically opened. Before you just need to associated .jnlp with java web launcher. Thx to putting me on the right track :)

I know this is an old thread, so my apologies for resurrecting it.

We're currently struggling with this issue in our enterprise and have used the AutoOpenFileTypes policy which does work, but the files are still downloaded to the users downloads folder. This obviously is not appropriate for things like Citrix .ica files, in our case.

I've dug through the current Edge policy templates from the link, but haven't come across anything that seems to address this, but I could have missed something.
Have you tried to use the GPO for EDGE Always open PDF files externally.
Ciao, Mario
I have the same issue i tried to use the GPO for msedge to target
AutoOpenFileTypes = gpo set to ica
AutoOpenAllowedForURLs = gpo set to the address where ica is downloaded

This has been done using Computer or User Configuration

I also set edge://settings/downloads "Ask me what to do with each download" to disabled

Scenario: when browser is opened as none full screen mode , No Issue was Found
Scenario: if msedge Start-Process -FilePath "C:\Program Files (x86)\Microsoft\Edge\Application\msedge.exe" -Argumentlist " --kiosk https://www.google.com --edge-kiosk-type=fullscreen --new-window is launch via kiosk mode it always as to save as ica file before it automatically launched. I am using the same profle as none kiosk mode , also both are not in private mode , thus i am expecting the settings to be saved or use between kiosk mode and none kiosk mode , but its not happening

Thanks in Advance

@EdgarFerrerMoreno Just Sharing manage to resolve the kiosk mode issue for ICA file to always open without saveas /downloading the file

 

new-item HKCU:\Software\Policies\Microsoft\Edge\AutoOpenAllowedForURLs -force
new-item HKCU:\Software\Policies\Microsoft\Edge\AutoOpenFileTypes -force
new-item HKCU:\Software\Policies\Microsoft\Edge\FileSystemReadAskForUrls -force
new-item HKCU:\Software\Policies\Microsoft\Edge\FileSystemReadAskForUrls -force
new-item HKCU:\Software\Policies\Microsoft\Edge\FileSystemWriteAskForUrls -force
new-item HKCU:\Software\Policies\Microsoft\Edge\FileSystemWriteAskForUrls -force
new-item HKCU:\Software\Policies\Microsoft\Edge\ImagesAllowedForUrls -force
new-item HKCU:\Software\Policies\Microsoft\Edge\ImagesAllowedForUrls -force
new-item HKCU:\Software\Policies\Microsoft\Edge\InsecureContentAllowedForUrls -force
new-item HKCU:\Software\Policies\Microsoft\Edge\InsecureContentAllowedForUrls -force

sample values


new-itemproperty HKCU:\Software\Policies\Microsoft\Edge\AutoOpenAllowedForURLs -type String -name 1 -value https://www.google.com
new-itemproperty HKCU:\Software\Policies\Microsoft\Edge\AutoOpenFileTypes -type String -name 1 -value ica
new-itemproperty HKCU:\Software\Policies\Microsoft\Edge\FileSystemReadAskForUrls -type String -name 1 -value https://www.google.com
new-itemproperty HKCU:\Software\Policies\Microsoft\Edge\FileSystemWriteAskForUrls -type String -name 1 -value https://www.google.com
new-itemproperty HKCU:\Software\Policies\Microsoft\Edge\ImagesAllowedForUrls -type String -name 1 -value https://www.google.com
new-itemproperty HKCU:\Software\Policies\Microsoft\Edge\InsecureContentAllowedForUrls -type String -name 1 -value https://www.google.com