Google Voice no sound in Edge

Occasional Contributor

When using the browser interface to Google Voice, I get the warning banner:

"Your browser might prevent calls from ringing. Change your browser settings to allow voice.google.com to play sound."

I've not been able to figure out how to resolve the issue.

Worse, I get no sound when I make phone calls despite my audio settings testing OK.

Any suggestions?

Thanks.

2 Replies

I figured it out.
What's needed is to enable "Media autoplay" for "voice.google.com" in Edge Settings.

  1. Open Settings in Edge.
  2. Search for "Media autoplay".
  3. In search results under "All permissions" scroll down to "Media autoplay" and expand it with ">".
  4. Add "voice.google.com" to "Allow".

msedge_20220411-101848.737.png

 

I had this problem for years 🤦‍:male_sign:
Thanks, man, I don't need to switch to chrome anymore :))