SOLVED

Google home page not opening on start up of Edge

Copper Contributor

Hey, new to the forums, for some reason as of yesterday, when I start up Edge, I get a Microsoft home page even though I have Google.com as my home page and start up page. how do i stop this from happening, as I said above it was working fine until yesterday, I've not added any new software.
Version 91.0.864.37 (Official build) (64-bit)
Thank you for your help

34 Replies
Would be nice if there was an option to kill the new personal tab completely.
I just want https://www.bing.com/ and not that fancy new crap page!
thank you , this fixed the issues for Version 96.0.1054.43.
Yes, I get the same error. Also, the message Microsoft Edge closed unexpectedly, restore pages? Very annoying. How else are you supposed to close Edge other than clicking on the X in the top right hand corner? My home page will not always open, it goes to the Microsoft home page even though I have selected google.co.uk as my start page and my home page. What is unexpected about closing down a browser? This is nuts.

@dosi70

 (Replying a nearly a year after the initial question)


My PC suddenly developed this problem after running Edge with no difficulties. Nothing seemed to fix it. A few days later, I noticed that Windows Edge was mysteriously activated in the Windows 10 Startup list (Settings>Apps>Startup).

 

So I tried the following steps :-
Turned the slider button off (it's easily turned back on, so not irreversibly techie).
Restarted PC.
Opened Edge - initially received a "browser was turned off unexpectedly, do you want to return to the page?" type message.
Nope, I didn't. So I exited Edge.
Turned Edge back on. This time it started correctly on Google.

 

I am definitely no expert, but it seemed to be behaving as though Edge was being invisibly launched on Startup and already running in the background without any display. So when the user opens it manually, they aren't "launching" from scratch but just automatically creating a new tab with the MSN page featured as default. Possibly.

 

Whatever the reason, I hope this might help someone.

@mubbly4871 

Yes, I had 12 instances of Microsoft Edge opening in the Start up list, so I am disabling it to see the effect. Also, I changed the Icon properties Link to show www.Google.co.uk That works OK. 

None of the suggestions solved it, so I found an extension with the name Custom New Tab URL which allows me to set it exactly like I want it to be.
Should have been a native feature and not something that requires a 3rth party solution, but seems like MS doesn't really care about that either.

Just experienced this issue following the March 2022 updates.
It stopped both the Edge and Chrome browser start-up tabs appearing.

This fixed it for me:
three dots
settings
start, home and new tabs
scroll down to the bottom and turn off Preload the new tab page for a faster experience
restart PC/Laptop

Both Edge and Chrome now opening start pages.......

Edge: Version 100.0.1185.39 (Official build) (64-bit)
Chrome: Version 100.0.4896.88 (Official Build) (64-bit)

@Pete Stevens 

Hello, and thank you for this.

 

This looked like a good and nicely practical solution, so I thought I'd try it.

 

In the process I noticed my New Tab Preload setting was already "Off", so perhaps this was the reason things worked.

 

However, interestingly, whatever permutation I run now - Edge on or off in Startup and New Tab Preload on or off (plus necessary Restarts), Google is loading as the homepage perfectly. This is baffling but at least in the right way.

Just wondering if you have tried to open a second Edge window after opening the first, right click on icon in task bar and select "Microsoft Edge" to start second window. I am finding the second window does not open with default start pages. I also had the initial window not opening, but your fix seems to have corrected that. Thanks for the post. Also finding that Chrome does the same.

Well i'm now confused - this morning Edge decided not to open "Startup pages" checked to see if the "faster experience" tab was disabled and it was.
Chrome opening with the start pages - no issues
Restart windows - still same issue
change tab to "faster experience" On - restart the machine and start pages are now working again.

Current Version of Edge: Version 100.0.1185.50 (Official build) (64-bit)
Opening a second Edge or Chrome instance only opens the Microsoft or Google Default page...

I found the same as you. I have over 40 computers setup using Group Policy to set the default home/startup pages. Some were working, while others not. I noticed some had an icon in the upper right corner of Edge saying an "update needed". I noted versions of edge before proceeding, 100.0.1185.50. I found that after clicking the icon to update, the Start page worked properly. Curiously the version of Edge did not change after the update and remained 100.0.1185.50. Other computers did not show the "update needed" and would not display the startup page.

I ended up setting a group policy to disabled "Enable preload of the new tab page for faster rendering". Once this policy was in place all computers loaded the proper start page. Not sure why one vs the other worked/updated but I now have them all working as desired again. Hope this helps someone else out there facing similar issues.

 

I did find a resolution to the second instance opening the Edge/Chrome default page.  I wasn't logged into a profile, yet somehow Edge was showing a profile using my email.  I don't use a profile for syncing across computers and never set one up.  I noticed this because the Edge icon in the taskbar had the "profile silhouette".  I removed this profile and now I can open multiple instances of Edge and each one starts with my defined start page.  I am thinking this has something to do with the original issue.  Is Edge/Chrome trying to force people into setting up a profile and placing all our "tracking info" on the web and this the result?

Interestingly Firefox does not have this feature and always opens the default start page.

@Schnittlauch 

I resolved this, kind of.

Go to "settings", " Privacy search and services"  scroll to the bottom and the last item is "address bar and search", "search engine used in the address bar", change it to google.

It still comes up as the microsoft startup page but if you type in the address bar it returns google results.

 

Just use the Edge Extension named Custom New Tab URL

I had the same problem with my site not opening. https://www.good9.app/ After the update, I was able to set Google as my homepage normally.